No, I am sure of it because I used my rl0 to connect to the LAN and download all kinds of stuff from the Internet. At that point my FreeBSD was a just box behind a Linksys router connected to the Comcast cable modem and it worked just fine. Then I added IP filtering, rebuilt the kernel, and changed rc.conf along with some other files according to the info I found on the Internet. Now neither of my card works. I got it working some time ago for awhile though - I ran sysinstall/Config/Networking and asked for DHCP search. I actually got the IP address, host name and DNS server IP address from Comcast but then something changed and I never saw it again. I am really dissapointed by how much time I have spent on it without any decent result.

Peter


From: Josh Paetzel <[EMAIL PROTECTED]>
To: [EMAIL PROTECTED]
CC: Peter Barton <[EMAIL PROTECTED]>
Subject: Re: DHCP help
Date: Sun, 8 Aug 2004 18:33:47 -0500

On Sunday 08 August 2004 18:10, Peter Barton wrote:
> Hello -
>
> I have been struggling with my DHCP connection for quite some time
> and even though my interent search yielded some information that I
> used, the whole thing still won't work. My problem is that my
> dhclient never finds any DHCP servers on the Comcast network. The
> default dhclient that came with the installation simply times out,
> the other one that I 'make installed' according to the info posted
> at
> http://networking.ringofsaturn.com.Unix/ipnatdfirewall.php keeps
> complaining about my subnet(s). I would greatly appreciate any
> help, I have spent a lot of time on this without any luck.
>
> Thanks,
> Peter
>
>
> Here's my rc.conf------------------------------------
>
> # -- sysinstall generated deltas -- # Sat Jul 17 06:31:46 2004
> # Created: Sat Jul 17 06:31:46 2004
> # Enable network daemons for user convenience.
> # Please make all changes to this file, not to
> /etc/defaults/rc.conf. # This file now contains just the overrides
> from /etc/defaults/rc.conf.
>
> linux_enable="YES"
> moused_enable="YES"
> usbd_enable="YES"
> natd_enable="YES"
> natd_flags="-s -u -m"
> firewall_enable="YES"
> firewall_quiet="NO"
> firewall_logging_enable="YES"
> firewal_type="open"
> gateway_enable="YES"
>
> ifconfig_rl0="inet 192.168.254.1 up netmask 255.255.255.0"
> ifconfig_rl1="DHCP"
>
> #defaultrouter="192.168.1.1"
> hostname="bsd.peterbohm.com"
>

Perhaps you have the cables for rl0 and rl1 reversed?

Thanks,

Josh Paetzel
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

_________________________________________________________________
Donít just search. Find. Check out the new MSN Search! http://search.msn.click-url.com/go/onm00200636ave/direct/01/


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to