I am running gmake on freebsd from a folder and the makefile tries to access
the perl file two levels up and I am getting access denied. I get this even
when I login as su.
./../bin/extract_obj_names.pl: Permission denied
gmake: *** [elf/rt_obj.txt] Error 126

Can anyone help me circumvent this problem?

Mohammad Shaikh

-----Original Message-----
From: Bill Moran [mailto:[EMAIL PROTECTED] 
Sent: Thursday, August 12, 2004 10:30 AM
To: Mohammadparvez Shaikh
Subject: Re: make issues on freebsd

"Mohammadparvez Shaikh" <[EMAIL PROTECTED]> wrote:
> Thanks a lot. I got the gmake installed successfully. But now the issue is

> that when I run:
> gmake -f common.mak I get
> gmake: Circular common.mak <- common.mak dependency dropped.
> How can I work around this issue

Are you serious?  Are we supposed to be psychic?

If you want us to debug your Makefile, you're going to have to show us
your Makefile.

However, are you sure you know what you're doing?  What is this software
you're trying to compile?  Have you read the install docs?  The syntax
you describe is not typical at all, and is probably not right.  What
makes you think that gmake should be using common.mak?  That looks like
an included file to me (just based on the name).

Most software from the GNU world require the following incantation:
gmake install

> -----Original Message-----
> From: Bill Moran [mailto:[EMAIL PROTECTED]
> Sent: Wednesday, August 11, 2004 6:58 PM
> To: Mohammed Shaikh (Satyam Computer Services)
> Subject: Re: make issues on freebsd
> "Mohammed Shaikh (Satyam Computer Services)" <[EMAIL PROTECTED]>
> >
> >I tried exactly what you said.
> >Make install clean
> >
> >But it tried to search for make-3.80.tar.bz2 and tried fetching over the
> >net and did not find it. (I think because of our firewall). Now I have
> >ftp'd the file in the /usr/ports/distfiles/ the above file and tried
> >running it and found that it has dependencies on gettext.
> >I copied gettext* there and tried installing gettext and found it has
> >dependencies on some other stuff.
> Lucky for you, you're not the first person to have this problem, thus
> there are many workarounds.  First off, I apologize, I forgot that gmake
> created such a large dependency tree.
> First off, if you have a FreeBSD CD, the required files may be on it in
> the /distfiles directory, and you can copy them from there.
> Otherwise, it's possible to install gmake from the packages collection.
> The easiest way to do this is to run "/stand/sysinstall"  You can then
> choose to load the packages from a CD, or FTP (you might want to try
> FTP-passive)  Once in sysinstall, go to Configure, then Packages and
> what you choose after that depends on where you want to try to get the
> packages from.  If they're not on the CD, exit sysinstall and restart
> it, choosing FTP-passive.
> The gmake package is in devel section, same as in ports.  If you don't
> see it in the listing, it's because it's not available on the media
> you selected.  Exit sysinstall and restart, choosing a different media.
> I know it's on the FTP sites for sure, but you may have trouble
> accessing them.
> >How and where I can get everything from, so that I can get this running.
> I'm just a bit amazed that this is coming from microsoft.com ... that's
> >I don't know stuff about unix world as I am new.
> >Appreciate your help friends!!
> >
> >Thanks a lot
> >Mohammad Shaikh
> >  -----Original Message-----
> >From: Bill Moran [mailto:[EMAIL PROTECTED] Sent: Wednesday,
> >11, 2004 5:40 PM
> >To: Mohammed Shaikh (Satyam Computer Services)
> >Subject: Re: make issues on freebsd
> >
> >"Mohammed Shaikh (Satyam Computer Services)" <[EMAIL PROTECTED]>
> >wrote:
> >                                                        ^^^^^^^^^
> >                                                     Is this a joke?
> >
> > > What is the best place to get it? I tried
> > > www.freshports.org/devel/gmake/
> > > > But I got confused as there are too many links and its not clear
> > > exactly to do, to get it installed on my freebsd machine. I am
> > > relatively a newbie so please help
> >
> >Stop making your life difficult:
> >
> >cd /usr/ports/devel/gmake && make install clean
> >
> >then use gmake instead of make.
> >
> > > -----Original Message-----
> > > From: Pat Lashley [mailto:[EMAIL PROTECTED] > Sent: Wednesday, 
> >August 11, 2004 5:25 PM
> > > To: Mohammed Shaikh (Satyam Computer Services);
> > > Subject: Re: make issues on freebsd
> > > > --On Wednesday, August 11, 2004 17:19:52 -0700 "Mohammed Shaikh
> >(Satyam
> > > Computer Services)" <[EMAIL PROTECTED]> wrote:
> > > > > I have a program that can be compiled with no problems on SuSe
> > > but
> > > > when I try it on freebsd it gives plethora of errors. I have just
> > > copied
> > > > the whole directory tree from SuSe Linux machine onto freebsd
> >machine.
> > > > Can Anyone PLEASE help as I have to submit the compiled stuff on
> > > freebsd
> > > > It is probably using make constructs that are specific to GNU make.
> > > If you haven't already done so, install the devel/gmake port and try
> > > using 'gmake' instead of 'make'.
> > > > > > -Pat

Bill Moran
Potential Technologies
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to