I installed a clean FreeBSD 4.10 Release a few days ago. After finishing the install, i downloaded the latest nvidia driver
(NVIDIA-FreeBSD-x86-1.0-6113.tar.gz) at once. Unzipped to /tmp and typed "make install". It worked flawlessly.
The module loaded correctly (kldstat), I edited the X config file (nv->nvidia) and removed the comment from "module glx".
(by default module dri is commented, and glcore isnt there at all). Started X, the nvidia logo is visible for a second.

I installed bzflag from package, and it worked well for the first time. (got 100+ FPS, which means it uses opengl correctly)
I closed bzflag after a short play, and tryed to rerun it. That time the program was terribly slow (2-3 fps, which
seems to me using software mode instead of hardware acceleration.). It even coredumps if i load the kernel module
pcm for my Sb Live sound card. (not loading sound modules complains it only about opening device file).
Once the machine even suddenly rebooted itself, while i was away.

I installed tuxracer from packages too. It even didnt start, complaining about missing opengl module.
(Linux compat mode loaded properly)

I also tried a new kernel, without compiled AGP options, letting the driver use its nv-agp feature.

After that I read the nvidia readme file. It says using with 4.10 release i have to patch because of msync bug.
Applyed the 2 patch-file, recompiled kernel with: config MYKERNEL, make buildkernel KERNCONF=MYKERNEL,
installkernel KERNCONF=MYKERNEL. (nothing cvsupping) But it didnt help :(
After apllying the KDE-releated patch (from the FAQ section) it couldnt even compile the kernel successfully.

I am newbie at bsd, but would like to try hw accelerated 3D on my machine, any help is greatly appreciated.


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to