On Thursday 26 August 2004 12:19 am, Subhro Kar <[EMAIL PROTECTED]> 
> First of all, you need to read the manual page for cvsup. It is
> clearly stated that the option -L shows the amount of verbosity cvsup
> maintains. If you are running it from inside a script, then either
> you have to
> reduce the verbosity to 1 ie, the command will be cvsup -g -L 1
> supfile OR
> redirect the output to some file (if you want to look into it later)
> or to /dev/null to discard it.

Yes, I've read the cvsup man page, but hadn't considered that verbosity 
might cause a failure if it's not directed. I think that might have 
been my problem. I had previously been directing output to a file, but 
not recently.

> Secondly, You can always set up multiple crontabs. But since you are
> using && (ie doo only if prev was successful), that would works if
> the output of cvsup is properly dealt with.

Well, again I know cvsup is working, but I think the verbosity might be 
a problem in executing the next command; i.e., I think since it can't 
direct output, it does run cvsup but "fails" in the verbosity aspect, 
and therefore no more commands are executed after. In any event, I 
think I'll try it with cvsup -g -L 2 supfile > /dev/null 2>&1 (of 
course with the proper paths) and see what happens, and alternately try 
to direct output to a file the next time, as I'd like to have a log. 
I'll probably also change it to portsdb -Uu as Ivailo suggested, as I 
don't need to have it run quickly when it's a daily job done when I'm 

Thanks for the help.

- jt

> Regards
> S.
> On Thu, 26 Aug 2004 00:07:26 -0700, Joshua Tinnin 
> > OK, I have searched the archives, and I can't find that my question
> > has been answered previously, but please forgive me if that's
> > incorrect.
> >
> > I'm using (or rather trying to use) cron to update my ports tree
> > daily. I've tried several different combinations without success,
> > and lately this is what I have in my crontab file:
> >
> > /usr/local/bin/cvsup -g -L 2
> > /home/krinklyfig/supfiles/ports-supfile && /usr/local/bin/portindex
> > && /usr/local/sbin/portsdb -u
> >
> > It runs as root once a day. What appears to be happening is that
> > the cvsup is happening, but portindex is not, and because of the
> > latter portsdb -u doesn't either. The reason I know cvsup is
> > working is because portindex indicates that the ports tree has been
> > updated if I run it manually later, but running portversion before
> > manually running portindex will not indicate any changes. The cron
> > log doesn't show anything but the commands being executed. So, my
> > question is: is this type of command valid, or should each command
> > be separate? Or is it not working for some other reason?
> >
> > - jt
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to