On 31.05.2009, at 09:18, Adam McDougall wrote:

I encountered the same symptoms today on both a 32bit and 64bit
brand new install using gptzfsboot.  It works for me when I use
a copy of loader from an 8-current box with zfs support compiled in.
I haven't looked into it much yet but it might help you.  If you
want, you can try the loader I am using from:

Hi, thanx a lot for this hint. Meanwhile, I was almost giving up,
and had a try with ZFS on Root with GPT partitioning, using
gptzfsboot as the bootloader, a UFS root partition as boot
partition (gmirrored to both disks), and the rest (inclusive of a
zvol for swap!) on ZFS. This worked perfectly on the first try.
(if anyone is interested, I can post my commented command
series for that, but it's just a mix of the available tutorials on
the web..).

I'll be glad do give the zfs-only solution a new try.
Had the same impression, that the loader was involved in the
problem, but had no env at hand to build a -CURRENT right
away... (I did, in fact, repeat the dd-steps a zfsboot
bootloader from a recent 8- snapshot iso... with the results
being the same as before...).

Sidenote: I encountered a few panics when using rsync with the
HAX flags enabled (rsync -avxHAX from UFS to ZFS).
I'll try to figure out which one of the flags caused it...
(Hard links, ACLs, or eXtended attributes..).
Never had even the slightest problem with rsync -avx.

Thanx for posting me your loader,  I'll try with this tomorrow night!
(any hint, btw, on why the one in -STABLE seems to be
broken, or whether it has actually been fixed by now?)



2009/5/28 Lorenzo Perone:

I tried hard... but without success ;(

the result is, when choosing the disk with the zfs boot
sectors in it (in my case F5, which goes to ad6), the kernel
is not found. the console shows:

forth not found
definitions not found
only not found
(the above repeated several times)

can't load 'kernel'

and I get thrown to the loader prompt.
lsdev does not show any ZFS devices.


freebsd-stable@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscr...@freebsd.org"

Reply via email to