On Thursday 08 April 2010 12:55:44 Krutov Mikle wrote:
> >Number:         145513
> >Category:       usb
> >Synopsis:       New USB stack: no new devices after forced usb flash
> > detach Confidential:   no
> >Severity:       serious
> >Priority:       low
> >Responsible:    freebsd-usb
> >State:          open
> >Quarter:
> >Keywords:
> >Date-Required:
> >Class:          sw-bug
> >Submitter-Id:   current-users
> >Arrival-Date:   Thu Apr 08 11:00:15 UTC 2010
> >Closed-Date:
> >Last-Modified:
> >Originator:     Krutov Mikle
> >Release:        8.0-STABLE
> >Organization:
> >Environment:
> 
> FreeBSD takino.homeftp.org 8.0-STABLE FreeBSD 8.0-STABLE #0: Mon Mar  8
>  06:25:34 MSK 2010     r...@takino.homeftp.org:/usr/obj/usr/src/sys/TAKINO 
>  amd64
> 
> >Description:
> 
> After detaching the mounted usb-flash device, no new usb-devices are
>  detected. USB controller is     "device     = 'SB700 USB OHCI1 Controller"
> 
> >How-To-Repeat:
> 
> 1) attach (vfat-formated, did not test with other fs) flash device, mount
>  it 2) detach without umounting
> 3) try to attach another usb-device
> 4) see no new devices, no dmesg messages, nothing
> 

Hi,

That's because the UMASS detach is hanging, most likely.

Try to break into the kernel and get a backtrace.

--HPS
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to