Maksim Yevmenkin wrote:
2011/3/14 martinko<>:

I had a Logitech bluetooth mouse connected via USB BT dongle.  In the past I
used to load ng_ubt and bthidd and hcsecd to make the mouse work.  The same
I did for a friend on old PC-BSD.  But it appears that since moving to the
version 8.x we no longer need to load any of the above and the mouse works
out-of-box.  Unfortunately it does not respond to wheel movement (pressing
it does generate middle click).
are we talking about freebsd or pc-bsd here? i'm confused :)

there were no changes in this area in freebsd. you still need to load
ng_ubt(4) to recognize local bluetooth device (i.e. bluetooth dongle
connected to your computer). usually its done via loader.conf, i.e.
put something like


into /boot/loader.conf.

devd(8) will start/stop bluetooth stack as soon as it detects
ng_ubt(4) device arrival/departure.

bthidd(8), hcsecd(8) etc. are bluetooth service daemons, and, those
needs to be started. usually one puts something like


into /etc/rc.conf to start bluetooth services.

assuming all of the above is in place, and, mouse was paired
previously, then it will work "out-of-the-box"

Now this all is a bit surprising for me.  And I'm not sure which part of the
system is responsible for the behaviour -- kernel, USB stack, HAL, X11, .. ?
ng_ubt(4) driver for usb bluetooth devices
devd(8) responds to events and starts/stops bluetooth stack

  Also, I'd like to know how to make wheel working again.
can you please provide hid descriptor?


Hi Max,

Thank you for your reply.

Probably I wasn't clear. I am aware of how to enable BT mouse in FreeBSD, I used it for several years. I did the same for PC-BSD and it worked as expected. But now, with the same mouse on a friend's computer running (latest) PC-BSD, I do no need to do anything and it works. There is no ng_ubt loaded, yet I see /dev/ums0 and mouse works both in console and X11. The issue is that its wheel does not work. So I was confused as to how it can work out-of-box and why wheel is dead. One idea that occured to me is that BIOS recognises and emulates it (dongle + mouse), though that sounds strange. Btw, when I tried to set it up as usual (and as you wrote above), it stopped working (on that PC-BSD machine).


_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to