Hello,

sorry for the delay

> Probably I wasn't clear.  I am aware of how to enable BT mouse in FreeBSD, I
> used it for several years.  I did the same for PC-BSD and it worked as
> expected.

ok

> But now, with the same mouse on a friend's computer running (latest) PC-BSD,
> I do no need to do anything and it works.  There is no ng_ubt loaded, yet I
> see /dev/ums0 and mouse works both in console and X11.  The issue is that
> its wheel does not work.

well, i would guess that the mouse is recognized as usb mouse. this
could happen when bluetooth usb dongle connected to the computer is
operating in so called "hid mode". in this mode, bluetooth dongle is
NOT appearing as bluetooth device but rather than usb mouse, and,
possibly, as keyboard as well.

> So I was confused as to how it can work out-of-box and why wheel is dead.

if my guess above is correct, then it works out-of-the-box because
ums(4) (usb mouse) drivers attaches to it, and, moused(8) picks it up
as usb mouse. i'm guessing the wheel does not work because moused(8)
needs to be told about it.

>  One idea that occured to me is that BIOS recognises and emulates it (dongle
> + mouse), though that sounds strange.

sorry, i'm not sure i understand what do you mean. if bluetooth dongle
is in fact in hid mode then it will look like usb mouse.

> Btw, when I tried to set it up as usual (and as you wrote above), it stopped
> working (on that PC-BSD machine).

can you please check if you even have bluetooth device in this case? what does

# ngctl li

shows?

thanks
max
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to