Hi,

While testing FreeBSD on a new machine[1] with the Asus E35M1-I motherboard, I 
put a sata hard drive into an external "docking station"[2]
which connects via usb to the machine, and installed FreeBSD 8.2-release / 
amd64 on the hard drive. This worked fine, with just an occasional problem:
sometimes automatic root mount would fail, amd I would have to manually input 
"ufs:/dev/da0s1a" and then it would mount root and continue to boot.

Then I upgraded FreeBSD on that partition to 8.2-stable, and now the machine 
won't mount root from that device at all. I had to load the old kernel and boot 
from that.
Here is usbconfig output for the usb docking station:
root@kg-f3# usbconfig -u 3 -a 2 dump_device_desc
ugen3.2: <External Generic> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

  bLength = 0x0012
  bDescriptorType = 0x0001
  bcdUSB = 0x0200
  bDeviceClass = 0x0000
  bDeviceSubClass = 0x0000
  bDeviceProtocol = 0x0000
  bMaxPacketSize0 = 0x0040
  idVendor = 0x13fd
  idProduct = 0x1240
  bcdDevice = 0x0104
  iManufacturer = 0x0001  <Generic >
  iProduct = 0x0002  <External        >
  iSerialNumber = 0x0003  <HP2200BBG9H54A          >
  bNumConfigurations = 0x0001 

and config:
root@kg-f3# usbconfig -u 3 -a 2 dump_curr_config_desc
ugen3.2: <External Generic> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON


 Configuration index 0

    bLength = 0x0009
    bDescriptorType = 0x0002
    wTotalLength = 0x0020
    bNumInterfaces = 0x0001
    bConfigurationValue = 0x0001
    iConfiguration = 0x0000  <no string>
    bmAttributes = 0x00c0
    bMaxPower = 0x0001

    Interface 0
      bLength = 0x0009
      bDescriptorType = 0x0004
      bInterfaceNumber = 0x0000
      bAlternateSetting = 0x0000
      bNumEndpoints = 0x0002
      bInterfaceClass = 0x0008
      bInterfaceSubClass = 0x0006
      bInterfaceProtocol = 0x0050
      iInterface = 0x0000  <no string>

     Endpoint 0
        bLength = 0x0007
        bDescriptorType = 0x0005
        bEndpointAddress = 0x0081  <IN>
        bmAttributes = 0x0002  <BULK>
        wMaxPacketSize = 0x0200
        bInterval = 0x0000
        bRefresh = 0x0000
        bSynchAddress = 0x0000

     Endpoint 1
        bLength = 0x0007
        bDescriptorType = 0x0005
        bEndpointAddress = 0x0002  <OUT>
        bmAttributes = 0x0002  <BULK>
        wMaxPacketSize = 0x0200
        bInterval = 0x0000
        bRefresh = 0x0000
        bSynchAddress = 0x0000 

Any hints on what the problem might be?
Details, such as dmesg output (normal and verbose) on the FreeBSD page for the 
machine[3].
References:
1) http://sites.google.com/site/tingox/asus_e35m1-i
2) http://www.deltaco.se/products/items/itemid/(SI-7908US)/index.aspx
3) http://sites.google.com/site/tingox/asus_e35m1-i_freebsd
-- 
Torfinn

_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to