On Monday 06 February 2012 22:59:27 Bengt Ahlgren wrote:
> I tried out 8.2-STABLE (from Feb 3rd) on my IBM Thinkpad X40 to see
> whether the updates to usb fixed the resume stall problem with
> 8.2-RELEASE.  (The latter with the "gavin-usb-controller-patch" however
> worked very well on this system!)
> 
> Unfortunately, 8.2-STABLE didn't improve.  On the contrary, no usb
> devices at all work after resume, so this is kind of a regression.  I
> tested with a couple of different versions of the usb system and
> concluded that it is commit r229370 that makes the difference.
> 
> After resume, the console says:
> 
> uhub1: at usbus1, port 1, addr 1 (disconnected)
> uhub2: at usbus2, port 1, addr 1 (disconnected)
> uhub3: at usbus3, port 1, addr 1 (disconnected)
> uhub0: at usbus0, port 1, addr 1 (disconnected)
> 
> What can I do to debug this further?  It would be great to be able to
> sort this for 8.3.

Hi,

Some more info:

The code that executes the USB suspend and resume is located in:

/sys/dev/usb/controller/usb_controller.c

All devices should be re-connected again at resume.

If you have USB audio devices, try suspend/resume w/o those plugged.

--HPS
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to