Hans Petter Selasky <hsela...@c2i.net> writes:

> On Monday 06 February 2012 22:59:27 Bengt Ahlgren wrote:
>> I tried out 8.2-STABLE (from Feb 3rd) on my IBM Thinkpad X40 to see
>> whether the updates to usb fixed the resume stall problem with
>> 8.2-RELEASE.  (The latter with the "gavin-usb-controller-patch" however
>> worked very well on this system!)
>> Unfortunately, 8.2-STABLE didn't improve.  On the contrary, no usb
>> devices at all work after resume, so this is kind of a regression.  I
>> tested with a couple of different versions of the usb system and
>> concluded that it is commit r229370 that makes the difference.
>> After resume, the console says:
>> uhub1: at usbus1, port 1, addr 1 (disconnected)
>> uhub2: at usbus2, port 1, addr 1 (disconnected)
>> uhub3: at usbus3, port 1, addr 1 (disconnected)
>> uhub0: at usbus0, port 1, addr 1 (disconnected)
>> What can I do to debug this further?  It would be great to be able to
>> sort this for 8.3.
> Hi,
> Make sure you remove any other rc.d scripts which kldload/kldunload 
> ehci/ohci/uhci/... at suspend/resume.
> Send complete dmesg showing a suspend/resume cycle.
> Send output from usbconfig before and after suspend/resume.
> Thank you.

Thanks for the response!

I have put the complete verbose dmesg from new boot, insert of usb
memory, sleep, resume, (doesn't work), kldunload/kldload uhci/ehci,
insert usb memory, (works again), and a log of the shell session
covering the same here:


Both have annotations "==== <action>" for clarity.

Is it worthwhile to compile with USB_DEBUG and redo the above?

freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to