Hi Hans,

When I just run usbconfig I get 
ugen0.2: <Bose USB Audio Bose Corporation> at usbus0, cfg=0 md=HOST spd=FULL 
(12Mbps) pwr=ON

 I ran,
usbconfig -d ugen0.2  dump_device_desc dump_curr_config_desc
I've attached the output with this e-mail.

I pulled out the bose usb and ran
sysctl hw.usb.uaudio.debug=15 
and then plugged back in and it's still the same in dmesg. It says No 
Playback.  Interesting my mouse stopped working when I did this.



________________________________
 From: Hans Petter Selasky <hsela...@c2i.net>
To: freebsd-usb@freebsd.org 
Cc: Purushotham Nayak <nayak_purushot...@yahoo.com> 
Sent: Monday, February 6, 2012 12:05 PM
Subject: Re: Bose USB Audio No Playback
 
On Monday 06 February 2012 17:30:31 Hans Petter Selasky wrote:
> On Monday 06 February 2012 01:04:19 Purushotham Nayak wrote:
> > Hi All,
> > 
> > I have Bose companion USB I'm trying to get it to work with FreeBSD.  But
> > there's no playback. I've put the details below. Does anyone know what
> > could be the reason there is no playback?
> 
> Hi,
> 
> Can you dump the device and configuration descriptor using usbconfig?
> 
> usbconfig -d X.Y dump_device_desc dump_curr_config_desc
> 
> Probably some descriptors are matching or the sample rate is too high/low.
                              ^^^ are not
Also try:

sysctl hw.usb.uaudio.debug=15

Before plugging the device.

--HPS

Attachment: bose.usbconfig
Description: Binary data

_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to