On Wednesday 08 February 2012 00:59:12 Purushotham Nayak wrote:
> Hi Hans,
> When I just run usbconfig I get
> ugen0.2: <Bose USB Audio Bose Corporation> at usbus0, cfg=0 md=HOST
> spd=FULL (12Mbps) pwr=ON
>  I ran,
> usbconfig -d ugen0.2  dump_device_desc dump_curr_config_desc
> I've attached the output with this e-mail.
> I pulled out the bose usb and ran
> sysctl hw.usb.uaudio.debug=15
> and then plugged back in and it's still the same in dmesg. It says No
> Playback.  Interesting my mouse stopped working when I did this.


Try this command:

sysctl hw.usb.uaudio.default_channels=6

Then replug your device.

Does it work?

You can also set this in:


I think the problem is that that your device is having a lot of channels, and 
should really be using High Speed USB. The device might not work correctly 
when connected through a High Speed HUB. Connect it directly to your PC/MAC!


                switch (usbd_get_speed(udev)) {
                case USB_SPEED_LOW:
                case USB_SPEED_FULL:
                         * Due to high bandwidth usage and problems
                         * with HIGH-speed split transactions we
                         * disable surround setups on FULL-speed USB
                         * by default
                        channels = 2;
                        channels = 16;

freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to