On Sun, 18 Mar 2012, Warren Block wrote:

On Sun, 18 Mar 2012, Fabio Dive wrote:

Hello people!

I write you because I have got a problem with the uplcom driver
on FreeBSD 9.0, I tried a lot of different things, read all I found,
manpages, forums, irc, google but still not able to solve my problem.

I need to connect to my remote Alix board,
the remote console setup is 19200 8N1.
I am using a short USB Prolific Tec.. serial cable adapter with a
NULL modem cable, the last one plugged one side to the Alix board,
the other side to the adapter cable.

Under Linux Debian everything is fine, so the hardware and cables
should be ok, under Linux I used minicom and cu and tip without problems.
With FreeBSD and NetBSD, big problems..the result is always
the same, I can receive but I cannot transmit.

(working as root)
*cu -t -s 19200 -l /dev/cuaU0
write: Device not configured
(I can't transmit but I can receive the output if I reboot the remote
alix board)

Add the user to the dialer group. If that doesn't do it, make sure the user has write permission to the USB device and /dev/cuaU0.

Managed to locate my PL2303 cable, and it works on 9-stable amd64 built
yesterday:

  % cu -l /dev/cuaU0 -s 19200
  can't open log file /var/log/aculog.
  Connected
  AT
  OK
  ~
  [EOT]

I typed the "AT". If the USB cable is disconnected and reconnected while cu still has it open, typing a character produces

  write: Device not configured

because the device disappeared when the USB cable was unplugged. The send and receive LEDs on this modem also both go on, meaning some data is being continuously sent and echoed.

/etc/devfs.rules (just the USB ones)

  [localrules=10]
  add path 'ugen*' mode 0660 group operator
  add path 'usb/*' mode 0660 group operator

The user is a member of both dialer and operator groups.

If it still does not work for you, check loader.conf and rc.conf for nonstandard settings.
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to