One more point:

I have tested the disk on the same hardware with yet another hub with
some interesting results:

Hub with external power:
ugen7.2: <vendor 0x05e3> at usbus7
uhub12: <vendor 0x05e3 USB2.0 Hub, class 9/0, rev 2.00/77.64, addr 2> on usbus7
uhub12: 4 ports with 4 removable, self powered
ugen7.3: <PLATINUM> at usbus7
umass0: <PLATINUM My Drive 2.5, class 0/0, rev 2.10/1.00, addr 3> on usbus7
umass0:  SCSI over Bulk-Only; quirks = 0x4100
umass0:2:0:-1: Attached to scbus2
da0 at umass-sim0 bus 0 scbus2 target 0 lun 0
da0: <PLATINUM My Drive 2.5'' 2AJ1> Fixed Direct Access SCSI-5 device 
da0: 40.000MB/s transfers
da0: 476940MB (976773168 512 byte sectors: 255H 63S/T 60801C)

Same hub without external power:
ugen7.2: <vendor 0x05e3> at usbus7
uhub12: <vendor 0x05e3 USB2.0 Hub, class 9/0, rev 2.00/77.64, addr 2> on usbus7
uhub12: 4 ports with 4 removable, self powered
ugen7.3: <PLATINUM> at usbus7
umass0: <PLATINUM My Drive 2.5, class 0/0, rev 2.10/1.00, addr 3> on usbus7
umass0:  SCSI over Bulk-Only; quirks = 0x4100
umass0:2:0:-1: Attached to scbus2
(probe0:umass-sim0:0:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0 
(probe0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(probe0:umass-sim0:0:0:0): SCSI status: Check Condition
(probe0:umass-sim0:0:0:0): SCSI sense: NOT READY asc:3a,0 (Medium not present)
da0 at umass-sim0 bus 0 scbus2 target 0 lun 0
da0: <ASMT 2105 0> Removable Direct Access SCSI-5 device 
da0: 40.000MB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present

Note that on the exact same hardware, the disk does work under windows.

-Guido

_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to