On Sat, Feb 09, 2013 at 11:36:15PM +0100, Hans Petter Selasky wrote:
> On Saturday 09 February 2013 21:04:03 Paul Schenkeveld wrote:
> > On Sat, Feb 09, 2013 at 03:56:53PM +0100, Hans Petter Selasky wrote:
> > > On Saturday 09 February 2013 13:51:56 Paul Schenkeveld wrote:
> > > > Hi,
> > > > 
> > > > I tried to use a USB pen camera with flash drive but get no more than:
> > > >   usbus7: port reset timeout
> > > >   uhub_reattach_port: port 1 reset failed, error=USB_ERR_TIMEOUT
> > > >   uhub_reattach_port: device problem (USB_ERR_TIMEOUT), disabling port
> > > >   1 usbd_set_config_index: could not read device status:
> > > >   USB_ERR_STALLED usbd_req_re_enumerate: addr=3, set address failed!
> > > >   (USB_ERR_STALLED,
> > > > 
> > > > ignored) usbd_req_re_enumerate: addr=3, set address failed!
> > > > (USB_ERR_STALLED, ignored) usb_alloc_device: Failure selecting
> > > > configuration index 0:USB_ERR_STALLED, port 1, addr 3 (ignored)
> > > > ugen7.3: <MagicPixel> at usbus7
> > > > 
> > > >   ugen7.3: <MagicPixel> at usbus7 (disconnected)
> > > > 
> > > > It works fine on a Macbook so I know it's not broken.
> > > > 
> > > > Any chance of getting this to work?
> > > > 
> > > > BTW I'm running 8.3-STABLE with a kernel built in May 2012.
> > > 
> > > Hi,
> > > 
> > > > With kind regards,
> > > 
> > > You should try 8-stable first. There has been some timing fixes in this
> > > area.
> > 
> > Just compiled a 8-STABLE kernel (svn rev 246578).  Initially I get the
> > almost same errors as above:
> > 
> >   usbus7: port reset timeout
> >   uhub_reattach_port: port 1 reset failed, error=USB_ERR_TIMEOUT
> >   uhub_reattach_port: device problem (USB_ERR_TIMEOUT), disabling port 1
> >   usbd_set_config_index: could not read device status: USB_ERR_STALLED
> >   usbd_req_re_enumerate: addr=3, set address failed! (USB_ERR_STALLED,
> > ignored) usbd_req_re_enumerate: addr=3, set address failed!
> > (USB_ERR_STALLED, ignored) usb_alloc_device: Failure selecting
> > configuration index 0:USB_ERR_STALLED, port 1, addr 3 (ignored) ugen7.3:
> > <MagicPixel> at usbus7
> >   ugen7.3: <MagicPixel> at usbus7 (disconnected)
> > 
> > > See: sysctl hw.usb.timings
> > 
> > Could not find documentation but with guessing and trying I got rid of
> > the first three messages using hw.usb.timings.port_powerup_delay=100:
> > 
> >   usbd_set_config_index: could not read device status: USB_ERR_STALLED
> >   usbd_req_re_enumerate: addr=3, set address failed! (USB_ERR_STALLED,
> > ignored) usbd_req_re_enumerate: addr=3, set address failed!
> > (USB_ERR_STALLED, ignored) usb_alloc_device: Failure selecting
> > configuration index 0:USB_ERR_STALLED, port 2, addr 3 (ignored) ugen7.3:
> > <MagicPixel> at usbus7
> >   ugen7.3: <MagicPixel> at usbus7 (disconnected)
> > 
> > Anything else I should try?
> 
> Hi,
> 
> Can you identify the limit at which your device works / does not work by 
> using 
> binary search.
> 
> Also try to play with the other tunables, and see what happens!

I already tried changing all other tunables, one by one, both lower and
higher values.  The second set of messages above is the bet I got.  It
was never recognized as a umass.

> --HPS

Thanks!

Paul Schenkeveld
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to