On 03/04/13 16:46, Krzysztof Parzyszek wrote:
On 3/4/2013 2:20 AM, Hans Petter Selasky wrote:


Looks like your device is not complying to SCSI standards??

Try this:

usbconfig -d X.Y add_quirk UQ_MSC_NO_INQUIRY

Replug your device.

Thanks.  I will try it tonight.  The device is a Mediasonic 4-bay
enclosure (which apparently do have buggy USB3 implementation).

What is surprising to me is that this combination (i.e. this device with
USB2) worked before, and now it doesn't.  I've found some other threads
related to similar umass issues, and in one of them someone described a
case of a memory stick which worked with FreeBSD, but after being used
with Linux or Windows, it would no longer work with the same FreeBSD
machine.  Do devices retain some sort of modifiable configuration data
even after power-off?

-Krzysztof

Hi,

Maybe you could reproduce that connecting your device through a so-called USB analyzer. Beagle sell cheap ones. If the device behaves differently when connected to for example FreeBSD after being plugged into another OS, would be interesting to know.

It is up to the manufacturer what they allow or not. Some flash sticks contain reprogrammable parts others do not.

--HPS
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to