The following reply was made to PR usb/179342; it has been noted by GNATS.

From: =?utf-8?Q?Hans_Petter_Selasky?= <hans.petter.sela...@bitfrost.no>
To: =?utf-8?Q?Takanori_Watanabe?= <takaw...@init-main.com>
Cc: =?utf-8?Q?miguelmclara=40gmail=2Ecom?= <miguelmcl...@gmail.com>, 
 =?utf-8?Q?bug-followup=40FreeBSD=2Eorg?= <bug-follo...@freebsd.org>
Subject: RE: usb/179342: Freebsd 10.0-current USB 3.0 not working
 (xhci_do_comand: Command timeout!)
Date: Fri, 7 Jun 2013 19:47:21 +0200

 This is a multi-part message in MIME format. Your mail reader does not
 understand MIME message format.
 --=_FOxI0JVt0ros0tqh1HRVDjPZNCyIUdOP9Jp8wmtmxJ+R8R9K
 Content-Type: text/plain; charset=utf-8
 Content-Transfer-Encoding: quoted-printable
 
 Can you try:=0D=0A=0D=0A=C2=A0=0D=0Ar251252=0D=0A=0D=0A=C2=A0=0D=0Aaswell=
 , that`s a header file change adjusting the IRQ rate of the XHCI controll=
 er.=0D=0A=0D=0A=C2=A0=0D=0A--HPS=0D=0A=0D=0A-----Original message-----=0D=
 =0AFrom:Takanori Watanabe <takaw...@init-main.com>=0D=0ASent:Fri 07-06-20=
 13 18:55=0D=0ASubject:Re: usb/179342: Freebsd 10.0-current USB 3.0 not wo=
 rking (xhci_do_comand: Command timeout!)=0D=0ATo:Hans Petter Selasky <han=
 s.petter.sela...@bitfrost.no>;=20=0D=0ACC:bug-follo...@freebsd.org; migue=
 lmcl...@gmail.com;=20=0D=0AIn message <51b1826a.3000...@bitfrost.no>, Han=
 s Petter Selasky wrote:=0D=0A>On 06/07/13 08:21, takaw...@init-main.com w=
 rote:=0D=0A>> Reverting the recent change on xhci.c fixes the problem for=
  me.=0D=0A>>=0D=0A>> --- head/sys/dev/usb/controller/xhci.c =C2=A02013/04=
 /23 06:26:54 =C2=A0 =C2=A0 249786=0D=0A>> +++ head/sys/dev/usb/controller=
 /xhci.c =C2=A02013/06/02 12:28:29 =C2=A0 =C2=A0 251254=0D=0A>>=0D=0A>=0D=0A=
 >Hi,=0D=0A>=0D=0A>If you look at the SVN log, there are only a few change=
 s in the XHCI=20=0D=0A>area. Could you identify exactly which change is t=
 he cause of the=20=0D=0A>problem=3F I don't see that any of the changes b=
 etween r1 and r2 should=20=0D=0A>affect the XHCI device init function, wh=
 ere it is failing.=0D=0A>=0D=0A>http://svnweb.freebsd.org/base/head/sys/d=
 ev/usb/controller/xhci.c=3Fview=3Dlog=0D=0A>=0D=0A>xhci_do_comand: Comman=
 d timeout!=0D=0A>usb_alloc_device: device init 2 failed (USB_ERR_TIMEOUT,=
  ignored)=0D=0A>usbgen0.2: <Unknown> at usbus0 (disconnected)=0D=0A>usb_r=
 eattach_port: could not allocate new device=0D=0A=0D=0Axhci.c 251251:2512=
 53 cause the problem for me.=0D=0A=0D=0A=0D=0A
 --=_FOxI0JVt0ros0tqh1HRVDjPZNCyIUdOP9Jp8wmtmxJ+R8R9K
 Content-Type: text/html; charset=utf-8
 Content-Transfer-Encoding: quoted-printable
 
 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://ww=
 w.w3.org/TR/html4/loose.dtd"><html>=0A<head>=0A  <meta name=3D"Generator"=
  content=3D"Zarafa WebAccess v7.1.0-36420">=0A  <meta http-equiv=3D"Conte=
 nt-Type" content=3D"text/html; charset=3Dutf-8">=0A  <title>RE: usb/17934=
 2: Freebsd 10.0-current USB 3.0 not working (xhci_do_comand: Command time=
 out!)</title>=0A  <style type=3D"text/css">=0A      body=0D=0A      {=0D=0A=
         font-family: Arial, Verdana, Sans-Serif ! important;=0D=0A       =
  font-size: 12px;=0D=0A        padding: 5px 5px 5px 5px;=0D=0A        mar=
 gin: 0px;=0D=0A        border-style: none;=0D=0A        background-color:=
  #ffffff;=0D=0A      }=0D=0A=0D=0A      p, ul, li=0D=0A      {=0D=0A     =
    margin-top: 0px;=0D=0A        margin-bottom: 0px;=0D=0A      }=0D=0A  =
 </style>=0A</head>=0A<body>=0A<p>Can you try:</p><p>&nbsp;</p><p>r251252<=
 /p><p>&nbsp;</p><p>aswell, that`s a header file change adjusting the IRQ =
 rate of the XHCI controller.</p><p>&nbsp;</p><p>--HPS</p><blockquote styl=
 e=3D"border-left: 2px solid #325FBA; padding-left: 5px;margin-left:5px;">=
 -----Original message-----<br /><strong>From:</strong>=09Takanori Watanab=
 e &lt;takaw...@init-main.com&gt;<br /><strong>Sent:</strong>=09Fri 07-06-=
 2013 18:55<br /><strong>Subject:</strong>=09Re: usb/179342: Freebsd 10.0-=
 current USB 3.0 not working (xhci_do_comand: Command timeout!)<br /><stro=
 ng>To:</strong>=09Hans Petter Selasky &lt;hans.petter.sela...@bitfrost.no=
 &gt;; <br /><strong>CC:</strong>=09bug-follo...@freebsd.org; miguelmclara=
 @gmail.com; <br />In message &lt;51b1826a.3000...@bitfrost.no&gt;, Hans P=
 etter Selasky wrote:<br />&gt;On 06/07/13 08:21, takaw...@init-main.com w=
 rote:<br />&gt;&gt; Reverting the recent change on xhci.c fixes the probl=
 em for me.<br />&gt;&gt;<br />&gt;&gt; --- head/sys/dev/usb/controller/xh=
 ci.c &nbsp;2013/04/23 06:26:54 &nbsp; &nbsp; 249786<br />&gt;&gt; +++ hea=
 d/sys/dev/usb/controller/xhci.c &nbsp;2013/06/02 12:28:29 &nbsp; &nbsp; 2=
 51254<br />&gt;&gt;<br />&gt;<br />&gt;Hi,<br />&gt;<br />&gt;If you look=
  at the SVN log, there are only a few changes in the XHCI <br />&gt;area.=
  Could you identify exactly which change is the cause of the <br />&gt;pr=
 oblem=3F I don&#39;t see that any of the changes between r1 and r2 should=
  <br />&gt;affect the XHCI device init function, where it is failing.<br =
 />&gt;<br />&gt;http://svnweb.freebsd.org/base/head/sys/dev/usb/controlle=
 r/xhci.c=3Fview=3Dlog<br />&gt;<br />&gt;xhci_do_comand: Command timeout!=
 <br />&gt;usb_alloc_device: device init 2 failed (USB_ERR_TIMEOUT, ignore=
 d)<br />&gt;usbgen0.2: &lt;Unknown&gt; at usbus0 (disconnected)<br />&gt;=
 usb_reattach_port: could not allocate new device<br /><br />xhci.c 251251=
 :251253 cause the problem for me.<br /><br /><br /></blockquote>=0A</body=
 >=0A</html>
 --=_FOxI0JVt0ros0tqh1HRVDjPZNCyIUdOP9Jp8wmtmxJ+R8R9K--
 
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to