The following reply was made to PR usb/181159; it has been noted by GNATS.

From: Hans Petter Selasky <>
To: Antonis Anastasiadis <>
Subject: Re: usb/181159: Problem attaching USB device
Date: Fri, 09 Aug 2013 22:25:31 +0200

 On 08/09/13 13:58, Antonis Anastasiadis wrote:
 >> Number:         181159
 >> Category:       usb
 >> Synopsis:       Problem attaching USB device
 >> Confidential:   no
 >> Severity:       non-critical
 >> Priority:       low
 >> Responsible:    freebsd-usb
 >> State:          open
 >> Quarter:
 >> Keywords:
 >> Date-Required:
 >> Class:          sw-bug
 >> Submitter-Id:   current-users
 >> Arrival-Date:   Fri Aug 09 12:00:00 UTC 2013
 >> Closed-Date:
 >> Last-Modified:
 >> Originator:     Antonis Anastasiadis
 >> Release:        9.2-RC1
 >> Organization:
 >> Environment:
 >> Description:
 > Using 9.2-RC1 system compiled with clang. The system is installed on a 
 > Hetzner EX40-SSD server.
 > The problem is that a USB device cannot be attached. The device is from the 
 > company Peppercon/Raritan that allows the remote control of a server.
  > It is connected to the VGA, keyboard and mouse ports of the server.
 There are some debug parameters under:
 sysctl hw.usb.timings
 Which might affect the behavior of your device. Make sure you have the 
 XHCI patch for 9.2-RC1 which was in a big late, if you compiled the code 
 > The exact error from the kernel output is:
 > usb_alloc_device: device init 2 failed (USB_ERR_IOERROR, ignored)
 > ugen0.2: <Unknown> at usbus0 (disconnected)
 > uhub_reattach_port: could not allocate new device
 Could you show the dmesg about which USB controller is at usbus0 in the 
 non-working case?
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to