>Number:         186110
>Category:       usb
>Synopsis:       connected over USB, only first document is printed
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-usb
>State:          open
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sat Jan 25 21:40:00 UTC 2014
>Originator:     Volker Nebel
>Release:        10.0 on a Macmini, 8.0 on an Acer laptop
FreeBSD macmini.ror.de 10.0-RELEASE FreeBSD 10.0-Release #1: Fri Jan 24 20:32:29
 CET 2014     r...@macmini.ror.de:/usr/obj/usr/src/sys/MACMINI  amd64
and for the ACER lapopt:
FreeBSD nebel.ror.de 8.0-RELEASE FreeBSD 8.0-RELEASE #3: Sat Jan 30 10:46:59 CET
 2010     r...@nebel.ror.de:/usr/obj/usr/src/sys/WENSDAY  i386


Perhaps I only fail because the handbook (which is excellent in many ways) provi
des only little info on how to connect a printer to an USB port. In case there i
s something special I overlooked, please let me know how I should do it and send
 this PR to Class www.
   My printer is an HP LaserJet 6MP without an USB interface (too old). It serve
s me fine when connected to a computer's parallel port. When I connect this prin
ter to a computer's USB port (with an adapter cable), only the first document (w
hat size ever) is printed. For further documents, printer starts blinking, stops
 blinking and does nothing.
   For modern computers no longer have a parallel port, I can only connect via U
   Obviously, the problem has nothing to with the spooling system, for it happen
s as well with [CMD=" "]cat test.ps > /dev/ulpt0[/CMD] issued twice: The first d
ocument is printed, any further not. (The printer understands Postscript.) Same
situation with /dev/unlpt0.
   I observe(d) the problem
- on my Acer Laptop with FreeBSD 8.0 (after [CMD=" "]kldload ulpt[/CMD])
- on my Apple Macmini with FreeBSD 10.0 (where ulpt is compiled into the kernel)
- on a laptop I had in the meantime of which I remember nothing except having Fr
eebSD installed
- on my Apple Macmini running under XUbuntu 10.4.3
   I do/did not observe the problem 
+ on my Apple Macmini running under MacOS X MountainLeopard (which I have 
completely replaced by FreeBSD) 
+ on my Acer Laptop using parallel port.
   Surprisingly the problem cannot be solved by turning the printer off and on a
gain. It can be solved by rebooting the computer (leaving the printer on). 
   When I issue [CMD=" "]lpr test.ps[/CMD] a 2nd time and [CMD=" "]lpq[/CMD], I
"waiting for lp to become ready (offline?)"
    When connected to the parallel interface interface, the printer worked fine
only in "polled mode". Unfortunately, I don't know how to tune /boot/device.hint
s for ulpt. And [CMD=" "]lptcontrol -p -d /dev/ulpt0[/CMD] returns: "lptcontrol:
 ioctl: Operation not supported by device".

Best regards,

[CMD=" "]cat test.ps > /dev/ulpt0[/CMD] twice. Or
[CMD=" "]lpr test.ps[/CMD] twice.
Or combinations.
For Ubuntu, they seem to have found a solution by tuning cups:
And the guys from Apple somehow solved it as well.

freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to