>Number:         188403
>Category:       usb
>Synopsis:       USB3 USB_ERR_TIMEOUT and USB_ERR_STALLED issues
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-usb
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Wed Apr 09 15:40:00 UTC 2014
>Closed-Date:
>Last-Modified:
>Originator:     Jason Seidel
>Release:        Freebsd 10 release/stable and 11.0-current
>Organization:
>Environment:
I have tried this with all current FreeBSD 10 versions.

FreeBSD nuc 11.0-CURRENT FreeBSD 11.0-CURRENT #1 r264292: Wed Apr  9 10:14:56 
EDT 2014     jseidel@nuc:/usr/obj/usr/src/sys/GENERIC  i386

>Description:
I have an intel NUC D34010WYKH, and there is an issue with the USB3 in release 
10 and 11. I was running freebsd 10 release and saw this issuebut i needed to 
upgrade to stable because release didnt contain the axge driver for a usb 
network adapter. after updating to stable, the driver was available but the usb 
errors were still there. I saw some messages about issues like this and that a 
fix was uploaded, so I went to current to see if it fixed the problem, but the 
issue was still there.

usb_alloc_device: set address 5 failed (USB_ERR_TIMEOUT, ignored)
usbd_setup_device_desc: getting device descriptor at addr 5 failed, 
USB_ERR_STALLED
Root mount waiting for: usbus1
usbd_req_re_enumerate: addr=5, set address failed! (USB_ERR_TIMEOUT, ignored)
usbd_setup_device_desc: getting device descriptor at addr 5 failed, 
USB_ERR_STALLED
Root mount waiting for: usbus1
Root mount waiting for: usbus1
usbd_req_re_enumerate: addr=5, set address failed! (USB_ERR_TIMEOUT, ignored)
usbd_setup_device_desc: getting device descriptor at addr 5 failed, 
USB_ERR_STALLED
Root mount waiting for: usbus1
usbd_req_re_enumerate: addr=5, set address failed! (USB_ERR_TIMEOUT, ignored)
usbd_setup_device_desc: getting device descriptor at addr 5 failed, 
USB_ERR_STALLED
Root mount waiting for: usbus1
Root mount waiting for: usbus1
usbd_req_re_enumerate: addr=5, set address failed! (USB_ERR_TIMEOUT, ignored)
usbd_setup_device_desc: getting device descriptor at addr 5 failed, 
USB_ERR_STALLED


$ pciconf -lv
hostb0@pci0:0:0:0:      class=0x060000 card=0x20548086 chip=0x0a048086 rev=0x09 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Haswell-ULT DRAM Controller'
    class      = bridge
    subclass   = HOST-PCI
vgapci0@pci0:0:2:0:     class=0x030000 card=0x20548086 chip=0x0a268086 rev=0x09 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Haswell-ULT Integrated Graphics Controller'
    class      = display
    subclass   = VGA
hdac0@pci0:0:3:0:       class=0x040300 card=0x20548086 chip=0x0a0c8086 rev=0x09 
hdr=0x00
    vendor     = 'Intel Corporation'
    class      = multimedia
    subclass   = HDA
xhci0@pci0:0:20:0:      class=0x0c0330 card=0x20548086 chip=0x9c318086 rev=0x04 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP USB xHCI HC'
    class      = serial bus
    subclass   = USB
none0@pci0:0:22:0:      class=0x078000 card=0x20548086 chip=0x9c3a8086 rev=0x04 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP HECI'
    class      = simple comms
em0@pci0:0:25:0:        class=0x020000 card=0x20548086 chip=0x15598086 rev=0x04 
hdr=0x00
    vendor     = 'Intel Corporation'
    class      = network
    subclass   = ethernet
hdac1@pci0:0:27:0:      class=0x040300 card=0x20548086 chip=0x9c208086 rev=0x04 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP HD Audio Controller'
    class      = multimedia
    subclass   = HDA
pcib1@pci0:0:28:0:      class=0x060400 card=0x20548086 chip=0x9c108086 rev=0xe4 
hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP PCI Express Root Port 1'
    class      = bridge
    subclass   = PCI-PCI
pcib2@pci0:0:28:3:      class=0x060400 card=0x20548086 chip=0x9c168086 rev=0xe4 
hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP PCI Express Root Port 4'
    class      = bridge
    subclass   = PCI-PCI
ehci0@pci0:0:29:0:      class=0x0c0320 card=0x20548086 chip=0x9c268086 rev=0x04 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP USB EHCI'
    class      = serial bus
    subclass   = USB
isab0@pci0:0:31:0:      class=0x060100 card=0x20548086 chip=0x9c438086 rev=0x04 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP LPC Controller'
    class      = bridge
    subclass   = PCI-ISA
ahci0@pci0:0:31:2:      class=0x010601 card=0x20548086 chip=0x9c038086 rev=0x04 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP SATA Controller 1 [AHCI mode]'
    class      = mass storage
    subclass   = SATA
none1@pci0:0:31:3:      class=0x0c0500 card=0x20548086 chip=0x9c228086 rev=0x04 
hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Lynx Point-LP SMBus Controller'
    class      = serial bus
    subclass   = SMBus
none2@pci0:2:0:0:       class=0x028000 card=0x40708086 chip=0x08b18086 rev=0x73 
hdr=0x00
    vendor     = 'Intel Corporation'
    class      = network

# usbconfig
ugen1.1: <EHCI root HUB Intel> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) 
pwr=SAVE (0mA)
ugen0.1: <XHCI root HUB 0x8086> at usbus0, cfg=0 md=HOST spd=SUPER (5.0Gbps) 
pwr=SAVE (0mA)
ugen1.2: <product 0x8000 vendor 0x8087> at usbus1, cfg=0 md=HOST spd=HIGH 
(480Mbps) pwr=SAVE (0mA)
ugen1.3: <AX88179 ASIX Elec. Corp.> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) 
pwr=ON (248mA)
ugen1.4: <USB Receiver Logitech> at usbus1, cfg=0 md=HOST spd=FULL (12Mbps) 
pwr=ON (98mA)


>How-To-Repeat:
fresh install of freebsd exibits this issue.
>Fix:
I have gotten it to "somewhat" stabilize by adding 
hw.usb.xhci.xhci_port_route=-1 into /boot/loader.conf

>Release-Note:
>Audit-Trail:
>Unformatted:
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to