Hi!

I borrowed a Vodafone - Huawei K3772 Mobile stick for some days. It's a bit disappointing, that I could not use it under FreeBSD. This 3g modem is made by Huawei (the K3772z is made by ZTE) with vendorID: 0x12d1 and productID: 0x1526.


# usbconfig -d 4.3 dump_device_desc
ugen4.3: <Vodafone Mobile Broadband Huawei Vodafone Huawei> at usbus4, cfg=255 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)

  bLength = 0x0012
  bDescriptorType = 0x0001
  bcdUSB = 0x0200
  bDeviceClass = 0x0000
  bDeviceSubClass = 0x0000
  bDeviceProtocol = 0x0000
  bMaxPacketSize0 = 0x0040
  idVendor = 0x12d1
  idProduct = 0x1526
  bcdDevice = 0x0102
  iManufacturer = 0x0002  <Vodafone (Huawei)>
  iProduct = 0x0001  <Vodafone Mobile Broadband (Huawei)>
  iSerialNumber = 0x0000  <no string>
  bNumConfigurations = 0x0001

I tried to switch it to USB-modem mode, but none of the usb_quirks worked. And with EJECT_HUAWEI, I got an error, too.

# usbconfig -d ugen4.3 add_quirk UQ_MSC_EJECT_HUAWEI
Adding quirk 'UQ_MSC_EJECT_HUAWEI' failed, continuing.
#

Under Linux, with usb_modeswitch, I could switch it to modem, with the MessageContent="55534243123456780000000000000011062000000100000000000000000000" string, and after it, it will be Vendor=12d1 ProdID=14cf. There are some interesting information about this modem in this forum thread:

http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=4&t=1114

Is it possible, to use this modem under FreeBSD? And if yes, how?

Thanks,

Zahemszky, Gabor < Gabor at Zahemszky dot HU >

_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to