I tried to switch it to USB-modem mode, but none of the usb_quirks
worked. And with EJECT_HUAWEI, I got an error, too.

# usbconfig -d ugen4.3 add_quirk UQ_MSC_EJECT_HUAWEI
Adding quirk 'UQ_MSC_EJECT_HUAWEI' failed, continuing.
#

Did you load the u3g and usb_quirk modules first?


Yes. My method was:

- first I plugged in the stick.
- Found, that nothing know about it.
- Pulled out
# kldload u3g
- plugged it second time
- nothing
- pulled out
# kldload usb_quirk
# man usb_quirk
- plugged the stick
- tried all of the u3g quirks, found in the manual and in the usbconfig dump_quirk_names list
with the command:

usbconfig -d useg4.3 add_quirk UQ_MSC_EJECT_*

one after the other. Actually I've just found, that there is a remove_quirk subcommand, too.
Maybe I need to remove a quirk if it's not the correct one?

Under Linux, with usb_modeswitch, I could switch it to modem, with the

MessageContent="55534243123456780000000000000011062000000100000000000000000000"

string, and after it, it will be Vendor=12d1 ProdID=14cf. There are some
interesting information about this modem in this forum thread:


http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=4&t=1114

Is it possible, to use this modem under FreeBSD? And if yes, how?


Modeswitch is available under FreeBSD too. Check the ports


Hm, I didn't know about it, At the evening, I'll try it.


collection. Although we prefer putting the quirks into the kernel.

Isn't it a good idea to make it possible to add new quirks from userspace?

Thanks,

Gabor < Gabor at Zahemszky dot HU >
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to