On 12/22/14 10:14, Randall Fox wrote:
On Mon, Dec 22, 2014 at 12:42 AM, Hans Petter Selasky <h...@selasky.org>
wrote:

On 12/21/14 22:28, Randall Fox wrote:

On Sun, Dec 21, 2014 at 1:02 PM, Hans Petter Selasky <h...@selasky.org>
wrote:

  On 12/21/14 21:40, Randall Fox wrote:

  Did you update /etc/devd/usb.conf, install new kernel and reboot your


  system?

I actually had the FreeNAS team apply this fix to the nightly build and
I
created a whole new install based on their Nightly Build.  The DEVs put
the
fix in, and it must have been correct because it worked for someone
else.

Here is the link to the ticket for this:
https://bugs.freenas.org/issues/7153
It appears they are familiar with you!

I will try putting the usb.conf in the location you specify, to see if
that
works.  I would be surprised if the dev's missed this.



On Sun, Dec 21, 2014 at 12:24 PM, Hans Petter Selasky <h...@selasky.org>
wrote:

   On 12/21/14 21:21, Randall Fox wrote:


   Hi,



The following patches should fix your problem:

https://svnweb.freebsd.org/changeset/base/275790
https://svnweb.freebsd.org/changeset/base/275791

--HPS




  Can you get the dmesg when plugging your device?

--HPS


  uhid0: <Tripp Lite TRIPP LITE SMART1500RM2U, class 0/0, rev 1.10/2.0a,
addr 3> on usbus1
ugen1.3: <Tripp Lite> at usbus1 (disconnected)
uhid0: at uhub3, port 1, addr 3 (disconnected)
ugen1.3: <Tripp Lite> at usbus1
uhid0: <Tripp Lite TRIPP LITE SMART1500RM2U, class 0/0, rev 1.10/2.0a,
addr 3> on usbus1
ugen1.3: <Tripp Lite> at usbus1 (disconnected)
uhid0: at uhub3, port 1, addr 3 (disconnected)

I tried putting the usb.conf in /etc/devd and rebooting, but no change..


Hi,

This looks correct. Did you select the correct device profile?

Also, did you set the correct USB configuration number?

usbconfig -d X.Y dump_device_desc dump_curr_config_desc
usbconfig -d X.Y set_config 1

--HPS


I ran the set_config 1, but that didn't have any effect, nor did set_config
0.   the dump device & config is below.

I did not select any profile, I just plug the unit in and I get the
disconnect messages.

ugen1.3: <TRIPP LITE SMART1500RM2U Tripp Lite> at usbus1, cfg=0
md=HOST spd=LOW (1.5Mbps) pwr=ON (0mA)

   bLength = 0x0012
   bDescriptorType = 0x0001
   bcdUSB = 0x0110
   bDeviceClass = 0x0000
   bDeviceSubClass = 0x0000
   bDeviceProtocol = 0x0000
   bMaxPacketSize0 = 0x0008
   idVendor = 0x09ae
   idProduct = 0x3015
   bcdDevice = 0x020a
   iManufacturer = 0x0002  <Tripp Lite >
   iProduct = 0x0003  <TRIPP LITE SMART1500RM2U >
   iSerialNumber = 0x0004  <2351BY0SM820600181>
   bNumConfigurations = 0x0001


  Configuration index 0

     bLength = 0x0009
     bDescriptorType = 0x0002
     wTotalLength = 0x0022
     bNumInterfaces = 0x0001
     bConfigurationValue = 0x0001
     iConfiguration = 0x0000  <no string>
     bmAttributes = 0x00e0
     bMaxPower = 0x0000

     Interface 0
       bLength = 0x0009
       bDescriptorType = 0x0004
       bInterfaceNumber = 0x0000
       bAlternateSetting = 0x0000
       bNumEndpoints = 0x0001
       bInterfaceClass = 0x0003
       bInterfaceSubClass = 0x0000
       bInterfaceProtocol = 0x0000
       iInterface = 0x0000  <no string>

       Additional Descriptor

       bLength = 0x09
       bDescriptorType = 0x21
       bDescriptorSubType = 0x10
        RAW dump:
        0x00 | 0x09, 0x21, 0x10, 0x01, 0x00, 0x01, 0x22, 0xe4,
        0x08 | 0x04

       Endpoint 0

       bLength = 0x0007
       bDescriptorType = 0x0005
       bEndpointAddress = 0x0081  <IN>
       bmAttributes = 0x0003  <INTERRUPT>
       wMaxPacketSize = 0x0008
       bInterval = 0x0028
       bRefresh = 0x0000
       bSynchAddress = 0x0000


Hi,

There is no RNDIS device here! There is only a UHID device.

--HPS
_______________________________________________
freebsd-usb@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to