https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=200938

rkober...@gmail.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |rkober...@gmail.com

--- Comment #10 from rkober...@gmail.com ---
I can't say whether the psm flags are really still required. At some point in
the past 4+ years I have had my T520 I was having an issue with the mouse
freezing on resume. I was aware of the psm(4) flags that would force a reset as
well as tickle the ThinkPoint(TM) itself and put it into loader.conf where it
remains. It worked and my problems were gone. This was probably on FreeBSD8.

I am running moused, no longer using hald (for X) and that has been the case
for a while.

I run with the touchpad off and have not tried enabling Synaptics support and
then disabling the pad. That might work just fine. At least in the past I was
unable to get a proper three button mouse unless I disabled it (plus I keep
inadvertently moving the pointer and clicking things when it is enabled). If
enabling Synaptics support and using it to disable the pad keeps the
three-button working correctly and the pad, itself, dead, that would be fine.

I agree that this is almost certainly a psm(4) bug, but I am nowhere near to
being conversant enough with FreeBSD drivers to try debugging it myself. Last
drivers I wrote were in assembly language for VMS. Wrote several of these
including some really weird ones.

I'll post an update when I have tried this.

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
freebsd-usb@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-usb
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to