A friend gave me a usb modem recently.  The model is:
Multi-Tech Systems - Multi-Modem USB - MT5634ZBA

The Linux driver info is here:

When I plug this device into FreeBSD I get a ugen0 device.

So I tried hacking into the driver itself:

diff --git a/sys/dev/usb/serial/umodem.c b/sys/dev/usb/serial/umodem.c
index c1e8812..9886294 100644
--- a/sys/dev/usb/serial/umodem.c
+++ b/sys/dev/usb/serial/umodem.c
@@ -136,6 +136,7 @@ static const STRUCT_USB_HOST_ID umodem_host_devs[] = {
+       {USB_VP(0x06e0, 0xf107)},


Now I get the following:

Nov 10 19:19:54 spigot kernel: ugen3.3: <Multi-Tech Systems, Inc.> at usbus3
Nov 10 19:19:54 spigot kernel: umodem0: <Multi-Tech Win95 Modem USB> on usbus3 Nov 10 19:19:54 spigot kernel: umodem0: data interface 1, has CM over data, has no break
Nov 10 19:19:54 spigot kernel: umodem0: Can't setup transfer
Nov 10 19:19:54 spigot kernel: device_attach: umodem0 attach returned 6

I read the Linux driver and it seems pretty similar, although it does look like they have a ton more quirks and edge cases the handle. The file in Linux I'm looking at is: linux/drivers/usb/class/cdc-acm.c (this seems to make the most sense given the instructions given at ftp://ftp.multitech.com/usb/usb-linux2.txt).

I tried turning on sysctl hw.usb.debug=10 however after doing so it didn't seem to want to probe anymore.

Any ideas?

I can ship this modem to someone if they are interested and have a good idea how to fix.

thank you,

freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to