Bug ID: 211205
           Summary: USB_ERR_TIMEOUT errors after upgrade from 10.2
           Product: Base System
           Version: 10.3-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: usb

Created attachment 172668
dmesg output from Intel NUC running 10.3-RELEASE

Had 10.2-RELEASE running stable on an Intel NUC (i5) for the past six months. 
Decided to upgrade to 10.3-RELEASE using freebsd-update.

On the first boot with the new kernel I began experiencing problems with the
USB subsystem -- specifically, neither my USB keyboard nor USB mouse work
anymore.  Instead I get several warnings in the logs (and on the console):

Jul 18 12:16:47 ren kernel: usbd_setup_device_desc: getting device descriptor
at addr 1 failed, USB_ERR_TIMEOUT
Jul 18 12:17:19 ren last message repeated 3 times
Jul 18 12:17:30 ren kernel: usbd_setup_device_desc: getting device descriptor
at addr 1 failed, USB_ERR_TIMEOUT
Jul 18 12:17:30 ren kernel: ugen0.2: <Unknown> at usbus0 (disconnected)
Jul 18 12:17:30 ren kernel: uhub_reattach_port: could not allocate new device

When I boot without keyboard and mouse the machine boots as quickly as it
usually does and I see no obvious error messages.

I completed the upgrade process by calling "freebsd-update install" again to
install the userspace stuff.  Rebooted.  Did another fetch and install to make
sure I was up to date.

I searched online for the problem and found this thread:

and tried the suggested solution (tweak to /boot/loader.conf).  It had no
effect, so I removed it.

I have attached dmesg output of two boot cycles -- the first with the keyboard
(and the errors), and the second without.  In both cases, the XHCI and EHCI
controllers appear to be recognized without error.

usbconfig confirms:

ugen1.1: <EHCI root HUB Intel> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps)
pwr=SAVE (0mA)
ugen0.1: <XHCI root HUB 0x8086> at usbus0, cfg=0 md=HOST spd=SUPER (5.0Gbps)
pwr=SAVE (0mA)
ugen1.2: <product 0x8001 vendor 0x8087> at usbus1, cfg=0 md=HOST spd=HIGH
(480Mbps) pwr=SAVE (0mA)

I want to emphasize that the keyboard and mouse are the same units as prior to
the upgrade and were working with 10.2 without issue so this isn't strictly a
hardware compatibility issue.  Something changed in the 10.3 USB subsystem that
breaks select (low speed in this case) USB device instantiation.

Note also that I am plugging the keyboard and mouse into the rear ports of the
NUC, which I believe are USB2 only.  The Superspeed ports are on the front.  I
tried plugging the keyboard into the superspeed ports and I have the same
problem.  The devices won't instantiate.

You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to