Hello, Hans,

I have not tried a -STABLE kernel. My kernel is -p2, with a -p7 userland. I 
will give -STABLE a try in the morning.

There are no relevant USB options in the BIOS. The only settings are to disable 
specific ports (for security purposes). I looked for any legacy options, but 
there were none. 

I will let the list know how it goes with -STABLE. Thanks!

⁣Jan L. Peterson

Sent from TypeApp ​

On Feb 19, 2017, 02:52, at 02:52, Hans Petter Selasky <h...@selasky.org> wrote:
>On 02/19/17 10:04, Jan L. Peterson wrote:
>> Hi, folks,
>> I have a weird problem...
>> Hardware is an HP dc7900 small form factor PC.  OS is FreeBSD
>> 11.0-RELEASE-p7.  I am running the GENERIC kernel.
>> I have a USB ethernet adapter that contains a Realtek chip... the
>> ID is 0x0bda and the product ID is 0x8153.
>> If I plug this device into the machine while the system is already up
>> and running, it is detected and attached as ue0 on cdce0 (it appears
>> ugen3.2, no matter which of the several USB ports on the machine I
>> it into).
>> If the device is plugged into the machine when it boots up, nothing I
>> can do (short of unplugging it and replugging it) will make the
>> recognize that it is there.
>> I have tried the following:
>> 1.  played with hw.usb.timings.* values
>> 2.  usbconfig -d 3.1 set_config 255; usbconfig -d 3.1 set_config 0
>> (which deactivates the hub that the device is connected to and then
>> reactivates it)
>> 3.  did the same (set_config 255; set_config 0) on *all* of the usb
>> (ugen*.1)
>> 4.  turned on various hw.usb.*.debug options (which produced copious
>> debug info, but nothing containing the strings 8153, 0bda, or
>> 5.  tried various devctl rescan options (including pci0)
>> 6.  googled frantically for something similar to this problem to no
>> avail (well, I did come across some people with similar problems, but
>> their problems all seemed to be around the device coming up with the
>> wrong config and needing a SET_CFG_1 quirk set, which appears to
>> be in the kernel as of 2015 or so)
>> I've looked for ways to force the USB bus to rescan (hence the
>> stuff in number 2 above) but nothing I have tried seems to work.
>> Again, the device works fine if I unplug it from the machine and then
>> plug it back in.  It is detected, probes, and attaches just fine and
>> dandy.  The problem is that the machine is destined to be locked in a
>> cabinet at a remote location where there won't be anyone available to
>> unplug and replug it any time the machine needs a reboot.
>> To clarify... when I have the device plugged into the machine and I
>> reboot, the device is not detected or noticed by the OS in any way.
>> There is nothing relevant in dmesg or /var/log/messages.  usbconfig
>> devinfo do not see it at all.  If I unplug the device and plug it
>> in, it is recognized immediately and works fine.
>> Any ideas?
>Have you tried a 11-stable kernel?
>Have you tried disabling USB in the BIOS?
freebsd-usb@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-usb-unsubscr...@freebsd.org"

Reply via email to