皆さん、ありがとうございます。

Dobashiさんのアドバイスより
 >ports/packageは全て再インストールしなければなりません。 から

#pkg_delete -f Perl-5.8.9_2
として、
apache22のディレクトリでmake install cleanとしたら
無事インストールできました。
#pkg_infoでみたら
Perl-5-14.4_1になっていました。

エラーがでたらとりあえずpkg_deleteで消して進んでみます。

ありがとうございました。



 >(2013/10/08 14:30), kenji kawachi wrote:
 >> /libexec/ld-elf.so.1:Shared object "libcrypt.so.4" not found, require by
 >> "Perl 5.8.9"
 >> とエラーが出てきました。
 >
 >libcrypt.so.4 は FreeBSD 7.x のライブラリなので
 >ports の misc/compat7x をインストールするか
 >Perl を再インストールするかだと思います。
 >
 >> また、xorgをインストールしstaratxと打ったところ同じようなもので
 >> /libexec/ld-elf.so.1:Shared object "librycsrv.so.4" not found, require by
 >> "libxext.so.6"
 >
 >librycsrv.so.4 というのはわからなかったんですが
 >librpcsrv.so.4 の事であれば先に書いたのと同様。
 >
 >状況としては misc/compat7x をインストールして
 >インストール済みの ports を全て再コンパイル後
 >misc/compat7x をアンインストールという手順に
 >なるんじゃないかと。
 >
 >----
 >岡部 勝幸
 >_______________________________________________
 >freebsd-users-jp@freebsd.org mailing list
 >https://lists.freebsd.org/mailman/listinfo/freebsd-users-jp
 >To unsubscribe, send any mail to "freebsd-users-jp-unsubscr...@freebsd.org"

_______________________________________________
freebsd-users-jp@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-users-jp
To unsubscribe, send any mail to "freebsd-users-jp-unsubscr...@freebsd.org"

メールによる返信