こんにちは、山口と申します。
実は、linux-gtk2をportupgradeするとインストールエラーを起こします。原因
のログをどこに報告したらよいかわかりませんので、こちらのMLに投稿させてく
ださい。どうすれば、解決できるのでしょうか。
環境はFreeBSD6.1-p3 linux_base-fc4 i386
原因のログです
転載開始
--->  Upgrading 'linux-gtk2-2.4.14_4' to 'linux-gtk2-2.6.10' 
(x11-toolkits/linux-gtk2)
--->  Building '/usr/ports/x11-toolkits/linux-gtk2'
===>  Cleaning for rpm-3.0.6_13
===>  Cleaning for linux-glib2-2.6.6
===>  Cleaning for linux-atk-1.9.1
===>  Cleaning for linux-jpeg-6b.34
===>  Cleaning for linux-png-1.2.8_2
===>  Cleaning for linux-tiff-3.7.1
===>  Cleaning for linux-pango-1.8.1
===>  Cleaning for linux_base-fc-4_6
===>  Cleaning for linux-xorg-libs-6.8.2_5
===>  Cleaning for gmake-3.81_1
===>  Cleaning for automake-1.4.6_2
===>  Cleaning for autoconf-2.13.000227_5
===>  Cleaning for libtool-1.5.22_2
===>  Cleaning for popt-1.7_1
===>  Cleaning for gettext-0.14.5_2
===>  Cleaning for linux-fontconfig-2.2.3_5
===>  Cleaning for linux-expat-1.95.8
===>  Cleaning for perl-5.8.8
===>  Cleaning for m4-1.4.4
===>  Cleaning for libiconv-1.9.2_2
===>  Cleaning for linux-gtk2-2.6.10
===>  Vulnerability check disabled, database not found
===>  Extracting for linux-gtk2-2.6.10
=> MD5 Checksum OK for rpm/i386/fedora/4/gtk2-2.6.10-2.fc4.4.i386.rpm.
=> SHA256 Checksum OK for rpm/i386/fedora/4/gtk2-2.6.10-2.fc4.4.i386.rpm.
=> MD5 Checksum OK for rpm/i386/fedora/4/gtk2-engines-2.6.3-2.i386.rpm.
=> SHA256 Checksum OK for rpm/i386/fedora/4/gtk2-engines-2.6.3-2.i386.rpm.
===>   linux-gtk2-2.6.10 depends on file: /usr/local/bin/rpm2cpio - found
===>  Patching for linux-gtk2-2.6.10
===>  Configuring for linux-gtk2-2.6.10
--->  Backing up the old version
--->  Uninstalling the old version
--->  Deinstalling 'linux-gtk2-2.4.14_4'
--->  Installing the new version via the port
===>  Installing for linux-gtk2-2.6.10
===>   linux-gtk2-2.6.10 depends on file: 
/compat/linux/usr/lib/libglib-2.0.so.0 - found
===>   linux-gtk2-2.6.10 depends on file: /compat/linux/usr/lib/libatk-1.0.so.0 
- found
===>   linux-gtk2-2.6.10 depends on file: /compat/linux/usr/lib/libjpeg.so.62 - 
found
===>   linux-gtk2-2.6.10 depends on file: /compat/linux/usr/lib/libpng12.so.0 - 
found
===>   linux-gtk2-2.6.10 depends on file: /compat/linux/usr/lib/libtiff.so.3 - 
found
===>   linux-gtk2-2.6.10 depends on file: 
/compat/linux/usr/lib/libpango-1.0.so.0 - found
===>   linux-gtk2-2.6.10 depends on file: /compat/linux/etc/fedora-release - 
found
===>   linux-gtk2-2.6.10 depends on file: 
/compat/linux/usr/X11R6/lib/libXrender.so.1 - found
===>   Generating temporary packing list
===>  Checking if x11-toolkits/linux-gtk2 already installed
cd /usr/ports/x11-toolkits/linux-gtk2/work && /usr/bin/find * -type d -exec 
/bin/mkdir -p "/compat/linux/{}" \;
cd /usr/ports/x11-toolkits/linux-gtk2/work && /usr/bin/find * ! -type d | 
/usr/bin/cpio -pm -R root:wheel /compat/linux
/usr/bin/cpio: /compat/linux/usr/lib/libgdk-x11-2.0.so.0 not created: newer or 
same age version exists
/usr/bin/cpio: /compat/linux/usr/lib/libgdk_pixbuf-2.0.so.0 not created: newer 
or same age version exists
/usr/bin/cpio: /compat/linux/usr/lib/libgdk_pixbuf_xlib-2.0.so.0 not created: 
newer or same age version exists
/usr/bin/cpio: /compat/linux/usr/lib/libgtk-x11-2.0.so.0 not created: newer or 
same age version exists
28726 blocks
/usr/bin/gtk-query-immodules-2.0-32: error while loading shared libraries: 
libXfixes.so.3: cannot open shared object file: No such file or directory
*** Error code 127

Stop in /usr/ports/x11-toolkits/linux-gtk2.
*** Error code 1

Stop in /usr/ports/x11-toolkits/linux-gtk2.
--->  Restoring the old version
        ! x11-toolkits/linux-gtk2 (linux-gtk2-2.4.14_4) (install error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
転載終了

よろしくお願いします。

************************************************* 
山口法生(Norio Yamaguchi/EOS) 
   Email:[EMAIL PROTECTED]
*************************************************

メールによる返信