While testing VNET jails, I came upon the problem that the nfsv4 client on an VIMAGE enabled kernel crashed the system. Rick and Bjoern worked out a patch and I have worked through this and tested the following on kernels without VIMAGE (straight GENERIC) and with VIMAGE and the curvnet2 patch:

1a: NFSv3 and NFSv4 server - OK on hosts, not tested in jails as too many needed rc-scripts are nojail.
1b: NFSv3 and NFSv4 client - OK on hosts, does not work in jails.
2: mount zfs jailed file systems in jail - works in all cases but VNET jail crashes the host on shutdown after host has unmounted the file system mounten in the jail, see below. Stuck task cleared by jail shutdown????
3: umount zfs jailed file systems in jail - does not work in any jail.
4: cpusets work in all cases.

Have not tested FIB, have never used it and really don't know how to use it. If you want me to test it, please point me to some usage examples so I have something to work from.

Test case 1 was run on both physical and virtual machines, 2,3 and 4 only run on virtual.

You can find all crash info for case 2 here:

NFS mount in jails does not work, in a VIMAGE kernel:
jail1# mount /usr/ports
[tcp] nfsserver.test.local:/usr/ports: RPCMNT: clnt_create: RPC: Program not registered mount_nfs: Cannot immediately mount nfsserver.test.local:/usr/ports, backgrounding

In an GENERIC kernel, mount hangs:
jail1# mount /usr/ports
load: 0.29  cmd: mount_nfs 2155 [kqread] 1.29r 0.00u 0.01s 0% 1116k

jail1# mount /usr/ports
load: 0.26  cmd: mount_nfs 2158 [connec] 1.25r 0.00u 0.01s 0% 1056k

umount fails everywhere:
jail1# umount /usr/jail/
umount: unmount of [restricted] failed: Invalid argument


freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to