Hello everyone

Sorry if this is not an urgent problem, I just wanted to know if I'm doing
wrong or it cannot be done by now
Did some tests with bhyve and had success as I described in
http://www.emulsoft.com/bhyve-ufs.txt. But during my tests, I tried to make
a zfs root installation, all the procces went well (creation of zpool and
bootcode etc) but, got stuck with:

Consoles: userboot

FreeBSD/amd64 User boot, Revision 1.1
(root@, Sun Dec 23 01:00:34 UTC 2012)
can't load 'kernel'

Type '?' for a list of commands, 'help' for more detailed help.
OK lsdev
host devices:
    host0:   Host filesystem
disk devices:
    disk0:   Guest drive image
      disk0p1: FreeBSD boot
      disk0p2: FreeBSD swap
      disk0p3: FreeBSD ZFS
OK ls
open '/' failed: no such file or directory

For me it just looks like the userboot isnt able to load the pool right at
the start or it needs to use zfsloader. Am I right with that? Will it be
possible in the future?

Another issue that is out of the topic, it was that guests couldn't reach
another pc using wlan as the host bridged interface. With a wired ethernet
interface it worked perfectly.

I hope I'm clear with this information and sorry for bad english.

Thank you

Marcos Alves
Emulsoft Corporation
freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to