I’ve been trying to get bhyve to work on a system with the following specs:

FreeBSD 10.0 64 bit
ASUS P6T Deluxe
Intel i7 920

According to what I’ve researched my cpu should have the VT-D extensions.  
However many users of this motherboard have complained about ASUS not properly 
supporting VT-D with Xen and something about a problem with tables getting 
corrupt due to a problem with the bios.  On the third link below which is the 
Xen wiki it even states that this motherboard needs a bios update which is not 
available to the public.

https://communities.intel.com/thread/28389

http://vip.asus.com/forum/view.aspx?id=20090402224408018&SLanguage=en-us&board_id=1

http://wiki.xen.org/wiki/VTd_HowTo

I am curious though if this would be what would be causing my problem with 
bhyve?  I suppose I am willing to just by a new motherboard if so.  

I can run kldload vmm and I see a bunch of text fly by and then something about 
uhci interrupt problem.  As soon as that happens the messages repeats my 
network drops and no keyboard input.  However the message repeats and it 
doesn’t appear that the system has fully locked up otherwise.  However on 
another system that works I notice that kldload VMM does not show this 
information it just loads the module.

Is there a way I can gather more logs somehow so that I can determine what text 
is appearing before the uhci errors?  Perhaps some kind of dump procedure?  Or 
is there a way I can confirm that freebsd can properly see and utilize the VT-D 
extensions.  VirtualBox runs fine with the VT extensions enabled.  I also made 
sure VirtualBox wasn’t installed or loaded before I tried bhyve.  I’ve tried to 
research for a week or two before posting here.

Joe Maloney

_______________________________________________
freebsd-virtualization@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to