Hi,

I tried to get bhyve to run on my home server but got consistent
crashes as soon as I touch the network.

Hardware: Supermicro X9SPV-F3610ME-O (embedded i5) with 16GB RAM

Host kernels (+userland of the same version):
        10.0 RC5
        10.0 RELEASE
        10 STABLE

The kernel has been stripped (unneeded drivers and stuff like DEBUG,
AUDIT, CAPABILITIES, MAC removed)

Guest operating systems:
        9.2 RELEASE
        10.0 RELEASE

Procedure:
        # ifconfig tap0 create up
        # ifconfig bridge0 create up
        # ifconfig bridge0 addm tap0 addm em0
        # kldload vmm
        # mkdir /vm/test
        # cd /vm/test
        # ln -s /images/FreeBSD-10.0-RELEASE-amd64-disc1.iso release.iso
        # sh vmrun.sh -c 1 -m 512 -t tap0

        <do a default install, no games/ports, IPv4 DHCP, no IPv6>
        <add 'console "/usr/libexec/getty std.9600" unknown on secure' to
         /etc/ttys>
        <add 'ifconfig_vtnet0="DHCP"' to /etc/rc.conf>
        <reboot guest>

At the point where DHCP sends the first query I get a segmentation fault
and the guest stops.

I can provoke the same segfault by not putting the DHCP line into
rc.conf and trying to ifconfig vtnet0 or by adding tap0 to bridge0 in
the host after the guest has stopped.

Although it worked perfectly fine with bhyve a couple of months ago
(with an older build of 10.0-CURRENT that I don't have here anymore), I
suspected the hardware and tried the same on my Macbook Pro with Vmware
Fusion with a 10.0 RELEASE guest.

The stripped 10 STABLE guest segfaults in the same way, the other two
both work.

I bought the home server for building software for older releases
(mostly FreeBSD 8 and 9), my Macbook with Fusion is too slow and often
in use for other purposes.

Is this behaviour seen by others?

I can provide more details or core dumps if that helps locating/solving
the problem.

With kind regards,

Paul Schenkeveld
_______________________________________________
freebsd-virtualization@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to