On Mon, 03 Mar 2014 02:17:14 -0800
Julian Elischer <jul...@freebsd.org> wrote:

> On 3/2/14, 2:49 AM, Giovanni Mattera wrote:
> > good morning
> > I installed freebsd 10.0 on Hyper -V Windows Server 2012 R2.
> > I would like to enable the CARP protocol but is still in a state of init .
> > The error in dmessage is " ifa_del_loopback_route : deletion failed: 48" .
> > How do you configure CARP on Hyper -V ?
> > I've used both the card " Legacy Network " and " Network" but the result is
> > the same. We are available to pay for this.
> have you tried this kernel with real hardware?
Hello Julian
CARP with this kernel in other environment does work fine.
The issue is that carp interface never goes MASTER, it stay in INIT state w/out
going into MASTER state.
The error we see on dmesg is:  ifa_del_loopback_route : deletion failed: 48.

There is no block on MAC-ADDRESSES on Hyper-v, no firewall, nothing.

We have tried with de interface (lelacy) and hn interface: same issue.

this is the hn interface:
hn0: <Synthetic Network Interface> on vmbus0

this is the ifconfig output:

        ether 00:15:5d:2c:11:21
        inet6 fe80::215:5dff:fe2c:1121%hn0 prefixlen 64 scopeid 0x3 
        inet netmask 0xffffff00 broadcast 
        inet netmask 0xffffff00 broadcast vhid 
        carp: INIT vhid 1 advbase 1 advskew 0

In attach I provide you full dmesg output

I can provide you an ssh access to this freebsd virtual machine, no problem at 

Googling around we find many people facing the same issue (CARP on Hyper-v),
none was able to provide a solution in forums or mailing lists.

Looking forward to hear from you.

Best Regards

Cordiali Saluti
Maurizio Marini 
CoST - Computers Services and Technologies S.r.l.
Via Longhi, 13  - 20137 Milano
P. IVA   09585780159
Tel +39 02 45446.207
Fax +39 02 45446.333

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone
indicate. La diffusione, copia o qualsiasi altra azione derivante dalla
conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate
ricevuto questo documento per errore siete cortesemente pregati di darne
immediata comunicazione al mittente e di provvedere alla sua distruzione.
Grazie. This e-mail and any attachment are confidential and may contain
privileged information intended for the addressee(s) only. Dissemination,
copying, printing or use by anybody else is unauthorized. If you are not the
intended recipient, please delete this message and any attachment and advise
the sender by return e-mail. Thank you

Copyright (c) 1992-2014 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 10.0-RELEASE #0 r260789: Thu Jan 16 22:34:59 UTC 2014
    r...@snap.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
FreeBSD clang version 3.3 (tags/RELEASE_33/final 183502) 20130610
module vmbus already present!
module storvsc already present!
module hn already present!
module atapci_dis already present!
CPU: Intel(R) Xeon(R) CPU            5140  @ 2.33GHz (1262.62-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x6f6  Family = 0x6  Model = 0xf  Stepping = 6
  AMD Features=0x20100800<SYSCALL,NX,LM>
  AMD Features2=0x1<LAHF>
real memory  = 2147483648 (2048 MB)
avail memory = 2052059136 (1956 MB)
Event timer "LAPIC" quality 400
ioapic0: Changing APIC ID to 0
ioapic0 <Version 1.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
random: <Software, Yarrow> initialized
vmbus0: <Vmbus Devices> on motherboard
acpi0: <VRTUAL MICROSFT> on motherboard
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, f7f00000 (3) failed
cpu0: <ACPI CPU> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <32-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 UDMA33 controller> port 
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 7.1 on pci0
ata0: <Hyper-V ATA storage disengage driver> at channel 0 on atapci0
ata1: <ATA channel> at channel 1 on atapci0
pci0: <bridge> at device 7.3 (no driver attached)
vgapci0: <VGA-compatible display> mem 0xf8000000-0xfbffffff irq 11 at device 
8.0 on pci0
vgapci0: Boot video device
de0: <Digital 21140A Fast Ethernet> port 0xec00-0xec7f mem 
0xfebff000-0xfebfffff irq 11 at device 10.0 on pci0
de0: 21140A [10-100Mb/s] pass 2.0
de0: Ethernet address: 00:15:5d:2c:11:1a
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse Explorer, device ID 4
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
fdc0: <floppy drive controller (FDE)> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on 
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcbfff,0xcc000-0xcc7ff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: cannot reserve I/O port range
Timecounter "Hyper-V" frequency 10000000 Hz quality 10000000
Timecounters tick every 20.000 msec
storvsc0 on vmbus0
hyperv-utils0 on vmbus0
hyperv-utils0: Hyper-V Service attaching: Hyper-V Heartbeat Service

hyperv-kvp0 on vmbus0
hyperv-kvp0: Hyper-V Service attaching: Hyper-V KVP Service

hyperv-utils1 on vmbus0
hyperv-utils1: Hyper-V Service attaching: Hyper-V Shutdown Service

hyperv-utils2 on vmbus0
hyperv-utils2: Hyper-V Service attaching: Hyper-V Time Synch Service

storvsc1 on vmbus0
Netvsc probe... DONE 
hn0: <Synthetic Network Interface> on vmbus0
Netvsc initializing... hn0: Ethernet address: 00:15:5d:2c:11:21
Netvsc probe... DONE 
hn1: <Synthetic Network Interface> on vmbus0
Netvsc initializing... Already initialized!
hn1: Ethernet address: 00:15:5d:2c:11:22
random: unblocking device.
da0 at blkvsc0 bus 0 scbus1 target 0 lun 0
da0: <Msft Virtual Disk 1.0> Fixed Direct Access SCSI-4 device 
da0: 300.000MB/s transfers
da0: Command Queueing enabled
da0: 8192MB (16777216 512 byte sectors: 255H 63S/T 1044C)
cd0 at ata1 bus 0 scbus0 target 0 lun 0
cd0: <Msft Virtual CD/ROM 1.0> Removable CD-ROM SCSI-5 device 
cd0: 16.700MB/s transfers (WDMA2, ATAPI 12bytes, PIO 65534bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present
Netvsc initializing... Already initialized!
Timecounter "TSC" frequency 1262623248 Hz quality 800
Trying to mount root from ufs:/dev/da0p2 [rw]...
ifa_del_loopback_route: deletion failed: 48
carp: demoted by -240 to 0 (vhid removed)
hn0: promiscuous mode disabled
 Closing Device ...
 Closing Device ...
hn0: promiscuous mode enabled
carp: demoted by 240 to 240 (interface down)

Attachment: smime.p7s
Description: S/MIME cryptographic signature

Reply via email to