On 05/01/2014 11:00 am, Andre Goree wrote:
Hello,

I'm running libvirt 1.2.2 and QEMU 1.7.91 on an Ubuntu 12.04LTS host.
Prior to a recent upgrade, I've been able to run FreeBSD guests (both
10.0 and 9.2) perfectly fine without issue.  Now, this the
aforementioned versions, I'm running into a kernel panic almost
immediately after booting, same message with both 10.0 & 9.2:  "Fatal
trap 12: page fault while in kernel mode".

To ensure that it had nothing to do with my configuration [of the
guest OS] I've tried installing the guest from guest using
virt-install, however I still run into the same kernel panic.  It'll
be hard for me to post the output of the panic, so I'll try to show as
much info as possible via images[1].

Upon researching, I've come across a few threads (e.g., this one[2])
that appear to be related, but none have helped.  Any information that
you can provide to help me get to the root of this issue would be
greatly appreciated!

[1]http://www.drenet.net/images/panic1.png
http://www.drenet.net/images/panic2.png
http://www.drenet.net/images/panic_noacpi1.png
http://www.drenet.net/images/panic_noacpi2.png

[2]http://forums.freebsd.org/viewtopic.php?t=36761


After using my noggin a bit, I've determine the culprit to be atkbd. If I disable it via the bootloader with "set hint.atkbd.0.disabled=1", the vm will boot fine. HOWEVER, my problem then is that I cannot use the keyboard via VNC. I'm trying to figure out ways around this...any help would be much appreciated. I've already tried setting different flags for atkbd, but no matter which flag I set, I get the kernel panic -- ostensibly because atkbd is enabled (as it must be for a flag to be set for it).


--
Andre Goree
-=-=-=-=-=-
Email     - andre at drenet.net
Website   - http://www.drenet.net
PGP key   - http://www.drenet.net/pubkey.txt
-=-=-=-=-=-
_______________________________________________
freebsd-virtualization@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-virtualization
To unsubscribe, send any mail to 
"freebsd-virtualization-unsubscr...@freebsd.org"

Reply via email to