On 05/02/2014 3:42 pm, Andre Goree wrote:
On 05/02/2014 2:18 pm, Juergen Lock wrote:
In article <201405021800.s42i0tie094...@enceladus10.kn-bremen.de> you write:
In article <f946e633356b1161c0d43217f59893b9-62z4zxnhd7cstnjn9+b...@public.gmane.org> you write:
On 05/01/2014 11:00 am, Andre Goree wrote:

I'm running libvirt 1.2.2 and QEMU 1.7.91 on an Ubuntu 12.04LTS host. Prior to a recent upgrade, I've been able to run FreeBSD guests (both
10.0 and 9.2) perfectly fine without issue.  Now, this the
aforementioned versions, I'm running into a kernel panic almost
immediately after booting, same message with both 10.0 & 9.2: "Fatal
trap 12: page fault while in kernel mode".

To ensure that it had nothing to do with my configuration [of the
guest OS] I've tried installing the guest from guest using
virt-install, however I still run into the same kernel panic. It'll be hard for me to post the output of the panic, so I'll try to show as
much info as possible via images[1].

Upon researching, I've come across a few threads (e.g., this one[2]) that appear to be related, but none have helped. Any information that
you can provide to help me get to the root of this issue would be
greatly appreciated!



After using my noggin a bit, I've determine the culprit to be atkbd. If I disable it via the bootloader with "set hint.atkbd.0.disabled=1", the vm will boot fine. HOWEVER, my problem then is that I cannot use the keyboard via VNC. I'm trying to figure out ways around this...any help would be much appreciated. I've already tried setting different flags
for atkbd, but no matter which flag I set, I get the kernel panic --
ostensibly because atkbd is enabled (as it must be for a flag to be set
for it).

I think you have hit this issue for which the workaround is a patch
to seabios:


Hm for some reason that link got truncated, try this one:






freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to

Lol, yeah, I was gonna say...but thanks!  Not sure if I'm into
implementing a patch vs. finding a way around this, and I'm wondering
why it reared it's head after an update to libvirt & qemu vs. earlier
in my testing -- makes me think it may be an unrelated, albeit similar
bug.  Thanks again Juergen.

Btw, from the link you posted:

"From: Michael Tokarev <m...@tls.msk.ru>
To: 737142-cl...@bugs.debian.org
Subject: Bug#737142: fixed in seabios 1.7.4-4
Source: seabios
Source-Version: 1.7.4-4

We believe that the bug you reported is fixed in the latest version of
seabios, which is due to be installed in the Debian FTP archive."

and on my host server having the issue:
"# dpkg -l |grep seabio
ii seabios 1.7.4-4~cloud0 Legacy BIOS implementation"

I'll try to determine which version of seabios I had running initially before the issue, however from what I can tell, an upgrade to the version that _should_ have fixed this appears be what caused my issue in the first place, heh.

Andre Goree
Email     - andre at drenet.net
Website   - http://www.drenet.net
PGP key   - http://www.drenet.net/pubkey.txt
freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to