since yesterday I have a weird problem. I cannot display VirtualBox
_guest_ consoles remotely anymore (the GUI for configuration works).

It worked two weeks ago and I am not aware of any changes.

I am running Virtualbox headless on a server but use the GUI for installs
when needed. I forward ssh (-X) and use "su -m" to keep the DISPLAY
environment variable(DISPLAY=localhost:10.0) and xauth.

Two weeks ago I did just that,

1. started "VirtualBox",
2. created a VM and a disk,
3. attached an ISO disk
4. pressed start and the "BIOS" appeared

Yesterday it all goes up to step 3- just 4 does not work. I get an error
instead of the BIOS screen, and on the server I get:

X11 connection rejected because of wrong authentication.

I checked all variables and parts - nothing has changed since the last
install that worked a fortnight ago.

Same kernel, same VirtualBox, same xauth, same desktop.

# uname -a
FreeBSD DellT620one.vv.fda 10.1-PRERELEASE FreeBSD 10.1-PRERELEASE #0 r273569: Fri Oct 24 14:43:34 AEDT 2014 r...@dellt410two.vv.fda:/usr/obj/usr/src/sys/IPSEC amd64
# pkg info | grep virtual
virtualbox-ose-4.3.18 General-purpose full virtualizer for x86 hardware
virtualbox-ose-kmod-4.3.18     VirtualBox kernel module for FreeBSD

The desktop Oracle Linux 6.5.

I used this on the 28th of October successfully. No fresh installs/upgrades since, I believe.

I can open X11 clients remotely (e.g. the VirtualBox control GUI works - just not the guest console)

Do you have any ideas what could go wrong?

Thanks for ideas
freebsd-virtualization@freebsd.org mailing list
To unsubscribe, send any mail to 

Reply via email to