https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=193826

--- Comment #3 from Henry Hu <henry.hu...@gmail.com> ---
(In reply to Adrian Chadd from comment #2)
> Hi!
> 
> I just fixed it in -HEAD. Please update and give it a whirl!
> 
> Thanks!
> 
> 
> 
> -adrian

I updated iwn and net80211 directory, and rebuilt the kernel. I keep wlandebug
scan on.

After one day, when I came back, the system is disconnected.
ifconfig says

wlan0: flags=8c43<UP,BROADCAST,RUNNING,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu
1500
        ether c4:85:08:82:da:5c
        inet 192.168.1.110 netmask 0xffffff00 broadcast 192.168.1.255 
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: IEEE 802.11 Wireless Ethernet MCS mode 11ng (autoselect)
        status: no carrier
        ssid "" channel 60 (5300 MHz 11a)
        country US authmode WPA1+WPA2/802.11i privacy ON deftxkey UNDEF
        powersavemode CAM powersavesleep 100 txpower 14 bmiss 10 mcastrate 6
        mgmtrate 6 scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250
        roam:rssi 7 roam:rate 12 wme roaming MANUAL
        groups: wlan 

and in messages, I see

Dec 22 19:28:40 pepsi kernel: [88:1f:a1:3e:9f:a9] new beacon on chan 60 (bss
chan 60) "Overbreaker5G" rssi 9
Dec 22 19:28:40 pepsi kernel: [88:1f:a1:3e:9f:a9] caps 0x1511 bintval 100 erp
0x0 country [US  36-43,30 100-104,30 132-134,30 149-153,30]

repeating over and over.

> wpa_cli status
Selected interface 'wlan0'
wpa_state=SCANNING
ip_address=192.168.1.110
address=c4:85:08:82:da:5c

I tried the old workaround: ifconfig wlan0 mode auto

wlan0: flags=8c43<UP,BROADCAST,RUNNING,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu
1500
        ether c4:85:08:82:da:5c
        inet 192.168.1.110 netmask 0xffffff00 broadcast 192.168.1.255 
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: IEEE 802.11 Wireless Ethernet MCS (autoselect)
        status: no carrier
        ssid "" channel 60 (5300 MHz 11a)
        country US authmode WPA1+WPA2/802.11i privacy ON deftxkey UNDEF
        powersavemode CAM powersavesleep 100 txpower 14 bmiss 10 mcastrate 6
        mgmtrate 6 scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250
        roam:rssi 7 roam:rate 12 wme roaming MANUAL
        groups: wlan 

But nothing changed.

Then I tried "ifconfig wlan0 scan". I see this:

Dec 22 19:30:27 pepsi kernel: wlan0: ieee80211_scanreq: flags 0x1b duration
0x7fffffff mindwell 0 maxdwell 0 nssid 0
Dec 22 19:30:27 pepsi kernel: wlan0: start_scan_locked: active scan already in
progress

Finally, I tried ifconfig wlan0 down; ifconfig wlan0 up, and it returns to
normal:

Dec 22 19:32:43 pepsi kernel: wlan0: ieee80211_cancel_scan: cancel active scan
Dec 22 19:32:43 pepsi kernel: wlan0: scan_task: loop start; scandone=1
Dec 22 19:32:43 pepsi kernel: wlan0: scan_task: out
Dec 22 19:32:43 pepsi kernel: wlan0: scan_task: done, [ticks 86384585, dwell
min 20 scanend 2214685618]
Dec 22 19:32:43 pepsi kernel: wlan0: ieee80211_cancel_scan: called; F_SCAN=0,
vap=match, CANCEL=0
Dec 22 19:32:43 pepsi kernel: wlan0: ieee80211_scan_flush
Dec 22 19:32:43 pepsi wpa_supplicant[412]: ioctl[SIOCS80211, op=26, val=0,
arg_len=0]: Operation not supported
Dec 22 19:32:43 pepsi wpa_supplicant[412]: ioctl[SIOCS80211, op=26, val=0,
arg_len=0]: Operation not supported
Dec 22 19:32:43 pepsi wpa_supplicant[412]: wlan0: CTRL-EVENT-TERMINATING 
Dec 22 19:32:43 pepsi dhclient[628]: connection closed
Dec 22 19:32:43 pepsi dhclient[628]: exiting.
.....

So it seems to stuck in the scan.

I checked the older logs, and found that there was a firmware error. You can
find the relevant log at:

http://pastebin.com/c1TA26sh

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
freebsd-wireless@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-wireless
To unsubscribe, send any mail to "freebsd-wireless-unsubscr...@freebsd.org"

Reply via email to