Wed, 12 Oct 2016 07:34:15 +0300 було написано Kevin Lo <>:

Thanks for testing! (I have got another one to simplify the process)
Can you approve that current tree (master) works without any (new) problems?

P.S. Known issue (present in the current driver too):
 - the card ACKs only some frames that were sent using CCK rates
(whilst sees all retransmissions - that can be seen in 'rx discard 'cuz dup'
counter via wlanstats)

I tried to use,
still no luck. BTW, there's a compilation error:

To ensure that the adapter is not faulty, I tested with the snapshots image (FreeBSD-12.0-CURRENT-amd64-20160829-r305028-memstick.img), rtwn(4) works fine.


On Tue, Oct 11, 2016 at 11:21:24PM +0300, Andriy Voskoboinyk wrote:

Tue, 11 Oct 2016 04:27:02 +0300 було написано Kevin Lo <>:

I have created 'pci_modified' branch to speed-up the process (RTL881*AU
not work with it for now); right now it contains (mostly) unmodified
initialization path from rtwn(4) driver.

If this version will work, I will revert some 'RTWN_PCI_WORKAROUND'
temporary blocks until the culprit is found.

> On Sat, Oct 08, 2016 at 02:18:54AM +0300, Andriy Voskoboinyk wrote:
>> Mon, 03 Oct 2016 03:55:23 +0300 було написано Kevin Lo
>> <>:
>> Hi!
> Hi Andriy,
>> Can you refresh the tree and retest it (dev.rtwn.0.debug=0x829f) ?
> I refreshed the tree and retested it, unfortunately it's still the same.
> Here's the log:
>> P.S. If Rx is still broken (status is always 0) try to execute
>> 'ifconfig wlan0 promisc'
> It doesn't help either :(

_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to