Doug Barton a écrit :
> My favorite login manager by far is slim, but the one thing that's
> bugged the heck out of me about it was the gymnastics I had to go
> through to get consolekit working for my xfce session. I was doing some
> research on line to try and find a more robust solution, and came across
> the notice that the newest version of slim now has consolekit support
> built in, so I upgraded our port, and voila! Good old startxfce4 works
> all by itself, and the consolekit stuff works just fine for reboot,
> shutdown, etc.
>
> FYI,
>
> Doug
>
Thanks for the update.

Just an issue here: graphics/libglut now seems to be required as a
dependency.


===>  Extracting for slim-1.3.3
=> SHA256 Checksum OK for slim-1.3.3.tar.gz.
=> SHA256 Checksum OK for slim-1.3.3.tar.gz.release.asc.
===>  Patching for slim-1.3.3
===>  Applying FreeBSD patches for slim-1.3.3
===>   slim-1.3.3 depends on file: /usr/local/libdata/pkgconfig/x11.pc -
found
===>   slim-1.3.3 depends on file: /usr/local/libdata/pkgconfig/xft.pc -
found
===>   slim-1.3.3 depends on file: /usr/local/libdata/pkgconfig/xmu.pc -
found
===>   slim-1.3.3 depends on file:
/usr/local/libdata/pkgconfig/xorg-server.pc - found
===>   slim-1.3.3 depends on file:
/usr/local/libdata/pkgconfig/xrender.pc - found
===>   slim-1.3.3 depends on file: /usr/local/bin/cmake - found
===>   slim-1.3.3 depends on shared library: jpeg.11 - found
===>   slim-1.3.3 depends on shared library: ck-connector.0 - found
===>   slim-1.3.3 depends on shared library: png15 - found
===>   slim-1.3.3 depends on shared library: freetype - found
===>   slim-1.3.3 depends on shared library: fontconfig - found
===>  Configuring for slim-1.3.3
/bin/mkdir -p /ports/build/ports/x11/slim/work/slim-1.3.3
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for XOpenDisplay in
/usr/local/lib/libX11.so;/usr/local/lib/libXext.so
-- Looking for XOpenDisplay in
/usr/local/lib/libX11.so;/usr/local/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/local/lib/libX11.so
-- Found Freetype: /usr/local/lib/libfreetype.so (found version "2.4.9")
CMake Error at
/usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:97
(MESSAGE):
  Could NOT find GLUT (missing: GLUT_glut_LIBRARY GLUT_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:288
(_FPHSA_FAILURE_MESSAGE)
  /usr/local/share/cmake/Modules/FindGLUT.cmake:68
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:76 (find_package)


-- Configuring incomplete, errors occurred!
*** Error code 1


_______________________________________________
freebsd-xfce@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-xfce
To unsubscribe, send any mail to "freebsd-xfce-unsubscr...@freebsd.org"

Reply via email to