On 5/11/06, Éderson Chimbida <[EMAIL PROTECTED]> wrote:
> On 5/11/06, Rafael Floriano Sousa Sales <[EMAIL PROTECTED]> wrote:
> > On 5/11/06, Éderson Chimbida <[EMAIL PROTECTED]> wrote:
> > > Dae pessoal, estou tentando rodar aplicações mono e .NET num Freebsd
> > > com apache+mono+mod_mono+xsp.
> > >
> > > Fiz a instalação do mono e apche pelos pacotes do ftp da freebsd.org,
> > > o mod_mono e o xsp eu baixei e compilei... até ain tudo ocorreu
> > > perfeitamente.
> > > Quando tento rodar os teste (exemplos) que vem com o xsp ele me
> > > responde com um erro 500 (Internal Server Error) e nada aparece no log
> > > do apche, e o mesmo acontece quando executo o server somente com o
> > > xsp:
> > >
> > > free# cd /usr/local/lib/xsp/test/ ; xsp --port 80
> > > xsp
> > > Listening on port: 80 (non-secure)
> > > Listening on address: 0.0.0.0
> > > Root directory: /usr/local/lib/xsp/test
> > > Hit Return to stop the server.
> > > Application_Start
> > > Application_End
> > > Tick caught an exception that has not been propagated:
> > > System.Threading.ThreadAbortException: Thread was being aborted
> > > in <0x00a97> System.Web.HttpApplication+<Pipeline>__1:MoveNext ()
> > > in <0x0001f> System.Web.HttpApplication:Tick ()
> > > System.Threading.ThreadAbortException: Thread was being aborted
> > >
> > > Server stack trace:
> > > in <0x000bc> System.Web.HttpApplication:Tick ()
> > > in <0x00037> System.Web.HttpApplication:Start (System.Object x)
> > > in <0x00068> 
> > > System.Web.HttpApplication:System.Web.IHttpAsyncHandler.BeginProcessRequest
> > > (System.Web.HttpContext context, System.AsyncCallback cb,
> > > System.Object extraData)
> > > in <0x001ab> System.Web.HttpRuntime:RealProcessRequest (System.Object o)
> > > in <0x0002c> System.Web.HttpRuntime:ProcessRequest
> > > (System.Web.HttpWorkerRequest wr)
> > > in <0x0000a> Mono.WebServer.MonoWorkerRequest:ProcessRequest ()
> > > in <0x00043> Mono.WebServer.BaseApplicationHost:ProcessRequest
> > > (Mono.WebServer.MonoWorkerRequest mwr)
> > > in <0x0037f> Mono.WebServer.XSPApplicationHost:ProcessRequest (Int32
> > > reqId, Int64 localEPAddr, Int32 localEPPort, Int64 remoteEPAdds, Int32
> > > remoteEPPort, System.String verb, System.String path, System.String
> > > queryString, System.String protocol, System.Byte[] inputBuffer,
> > > System.String redirect, IntPtr socket, Mono.WebServer.SslInformations
> > > ssl)
> > > in (wrapper remoting-invoke-with-check)
> > > Mono.WebServer.XSPApplicationHost:ProcessRequest
> > > (int,long,int,long,int,string,string,string,string,byte[],string,intptr,Mono.WebServer.SslInformations)
> > > in (wrapper xdomain-dispatch)
> > > Mono.WebServer.XSPApplicationHost:ProcessRequest
> > > (object,byte[]&,byte[]&,int,long,int,long,int,string,string,string,string,byte[],string)
> > >
> > > Exception rethrown at [0]:
> > >
> > > in (wrapper xdomain-invoke)
> > > Mono.WebServer.XSPApplicationHost:ProcessRequest
> > > (int,long,int,long,int,string,string,string,string,byte[],string,intptr,Mono.WebServer.SslInformations)
> > > in (wrapper remoting-invoke-with-check)
> > > Mono.WebServer.XSPApplicationHost:ProcessRequest
> > > (int,long,int,long,int,string,string,string,string,byte[],string,intptr,Mono.WebServer.SslInformations)
> > > in <0x00563> Mono.WebServer.XSPWorker:InnerRun (System.Object state)
> > > in <0x00022> Mono.WebServer.XSPWorker:Run (System.Object state)
> > >
> > >
> > > Alguem pode me ajudar a resolver esse problema, e deixar o apache
> > > servidno paginas aspx
> > >
> > > --
> > > Éderson H. Chimbida
> > > -------------------------
> > > Histórico: http://www.fug.com.br/historico/html/freebsd/
> > > Sair da lista: https://www.fug.com.br/mailman/listinfo/freebsd
> > >
> >
> > Olá,
> >
> > Não utilize os pacotes, eles não são oficiais e não possuem suporte
> > total, utilize o mono-merge, como ele você irá baixar os ports feitos
> > pelo core da novell.
> >
> > http://forge.novell.com/modules/xfmod/project/?bsd-sharp
>
> Ok... removi todos os pacotes, o xsp e mod_mono e estou compilando
> pelo ports que ele baixou do cvs da novell com o mono-merge... quando
> terminar digo se funcionou ou não !!!!

Tudo instalado pelo mono-merge e o XSP continua dando o mesmo erro...

>
> >
> > --
> > Rafael Floriano Sousa Sales
> > Segurança da  Informação
> > Tompast IT Services
> > e-mail: [EMAIL PROTECTED]
> > +55-11-3207-2457
> > +55-11-8433-2281
> > -------------------------
> > Histórico: http://www.fug.com.br/historico/html/freebsd/
> > Sair da lista: https://www.fug.com.br/mailman/listinfo/freebsd
> >
>
>
> --
> Éderson H. Chimbida
>


-- 
Éderson H. Chimbida
-------------------------
Histórico: http://www.fug.com.br/historico/html/freebsd/
Sair da lista: https://www.fug.com.br/mailman/listinfo/freebsd

Responder a