I think there is no regular maintainer for the Win32 client.  I
submitted a patch for the Win32 client a while ago -- I believe the
tracking number is PR#33445.  Marko looked at it and wrote his own
patch which improved parts of what I had written.  However, he only
committed his own patch, and certain fixes from my patch were never

 Perhaps that's because I did more than just fix what absolutely had
to be fixed, opting to the cursor code to a new file and such.
Anyway, I'm pretty new around here, but I would say go ahead and send
in what you did.  Perhaps it will improve upon what I submitted.
Hopefully someone will be able to tell you how to get your patch added
to the proper place in the tracking system.

  Regarding the server build, I was able to build everything fine
under MinGW/Msys from the SVN sources back when I was working on that
patch.  I didn't need to do "--disable-nls" or hack the config.h file.
I built the required libraries from source, except for readline.  I
ended up using the prebuilt readline package from the GNUWin32

  It looks to me like there is a problem with your build environment.
I don't think you should be using the libintl.a that's in
freeciv/intl/.  Perhaps configure can't find your libintl or can't use
it for some reason.  You should have gotten libintl from the gettext

  If I were you I would clean up and try the build from autogen on,
this time without "--disable-nls," looking for any errors or problems
related to dcgettext, libintl, libcharset, or libiconv in the
configure stage.  Hopefully you will see a test of one of these fail
and there will be some useful diagnostic information in config.log.



Hello.  I just joined this list, and I did a quick skim thruogh the last
few months archives.  Please forgive me if I'm bringing up stuff thats
already been dealth with.

I've been trying to build freeciv under windows using MinGW/MSys for the
past week or so.  I had success doing this a couple years ago, but I
hadn't played with it since.  I ran into problems when it tried to link
civserver.exe.  If I ran autogen.sh normally,  and then make I got this
at the link step for civserver:

multiple definition of `locale_charset'
first defined here
collect2: ld returned 1 exit status
make[3]: *** [civserver.exe] Error 1

So, I tried the suggestions in the Install-Windows document and passed
--disable-nls into autogen.sh.  Then I got this:

./libcivserver.a(stdinhand.o): In function
undefined reference to `_imp__libintl_fprintf'
:c:/chris/freeciv/server/stdinhand.c:1071: undefined reference to
:c:/chris/freeciv/server/stdinhand.c:1074: undefined reference to
:c:/chris/freeciv/server/stdinhand.c:1077: undefined reference to
:c:/chris/freeciv/server/stdinhand.c:1082: undefined reference to
more undefined references to `_imp__libintl_fprintf' follow
collect2: ld returned 1 exit

I finally figured out that I had to edit config.h and comment out this

Have I installed something wrong?  Do I need to pass more options to
autogen?  Or is there a problem with autogen/configure?

After I made the aforementioned change, the GTK client built just fine.
However, the win32 client gave me lots of errors.  I set about fixing
them, and I have a patch ready.  Should I email it to this mailing
list?  Inline or Attachment?

I'm also wondering how the most recent win32 clients were built.  Some
of the stuff I was fixing has been there for over a year, and prevented
compiling the win32 client.  I'm confused as to how a new build was
released last month.  Perhaps I'm doing something else wrong.

Chris Nash (aka Homr Zodyssey)

Freeciv-dev mailing list

Freeciv-dev mailing list

Reply via email to