URL:
  <http://gna.org/bugs/?15451>

                 Summary: Vote buttons give packet errors, but "/vote"
command works
                 Project: Freeciv
            Submitted by: jtn
            Submitted on: Monday 22/02/10 at 02:31
                Category: client
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: None
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 
         Discussion Lock: Any
        Operating System: None
         Planned Release: 

    _______________________________________________________

Details:

Just tried the voting system for the first time in a contrived situation to
see how it worked, and ran into this:

Started server with an existing savegame with "server/freeciv-server -f
savegame.sav.bz2", and started three local clients with different usernames
which connected to that server. Clients now in a pregame screen (with the
player/flag/nation/connection list, "More Game Options...", chat window,
"Ready" button).

Ran "cmdlevel basic" on the server. Then from one of the clients, tried
changing the "migration" option via the GUI (this is settable mid-game, don't
know if it should be). This triggered a vote, as expected, and all clients
popped up a voting bar.

However, clicking on any of the voting buttons on any of the clients gives
the server message


1: got a packet of type 149 outside S_S_RUNNING


(149 is PACKET_VOTE_SUBMIT in common/packets.def), which isn't what I was
expecting. Typing "/vote yes" in the client's chat window did work.

S2_2 r16893 (which is 2.2.0 plus today's post-unfreeze checkins).




    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?15451>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to