Follow-up Comment #2, bug #16769 (project freeciv):

[My guess at a solution appears at the bottom.]


I did a search of my computer for “nation” (as contents).

The file that you mention appears to be okay.

The “nations.ruleset” file in …/freeciv/civ1 is different, but has a
zulu line; this, too, appears to be okay.

These are the only two files that found.  Ditto “ruleset”.  


     Download Source

I have attached the file Info information about whence I got the download. 
My browser history seems to show that I started at SourceForge.  My memory
says that, when I was downloading a file (by which I mean that I do not
recall what file), there were two mirror sites, and I selected the second
one.  This matches with a “…download…” entry in my browser history,
which is

http://freeciv.wikia.com/wiki/Download#Mac_OS_X_Packages

; the second MacOS mirror site is

gna.org

.  I also have a item:

http://freeciv.wikia.com/index.php?title=Special:Outbound&f=Download&u=http%3A%2F%2Fdownload.gna.org%2Ffreeciv%2Fpackages%2Fmacosx%2Ffreeciv-sdl-2.2.3-leopard-intel.dmg

, which appears to be the download instance address.  


     Attempt to Fix Locally

I have run a Disk Utility check of my hard disc; it says that it is okay.  

I saved the file for which you gave the link, as nations.ruleset.txt.  (I had
to add myself in the permissions to do this.)  

I tried opening my saved game before making the (following) change, just in
case - same problem.

Then I renamed the existing file to “nations.ruleset  [original]”, and
renamed the new file by deleting the “.txt”.  When I ran the program…
same problem.  



     Checking the Save File

After some stuffing around with Terminal, I managed to get a readable copy of
the save file.  It does not have any apparent problems or errors.  



     SDL vs GTK2

Under the SDL build, the program displays the error message and then stops. 
I installed the GTK2 version; under this, the error message part is the same,
but there is also a “Start” button; clicking this results in a normal
game.  (It happens that the Zulus are not represented among the
“players”.)

[Blush (contingently)]  Having installed the GTK2 version… I have just
launched the SDL app; I noticed that the it has a start button as well.  (I
do not know enough about these things to know whether it is there because I
installed the STK2 version or not.)  Clicking this Start button has the same
effect — the game opens normally.  


     Deleting the “zulu” entry, et al.
I modified the “nations.ruleset” file, deleting the  zulu  line. 
Launching the SDL version and loading the original game resulted in the same
error occurring with the previous line — now the last line.

!!  I added an extra line-feed to the end of the file… no error.  I think
there must be a simple coding error in the loop processing.  (Conversely, one
would expect this to affect everyone.)


(file #10491)
    _______________________________________________________

Additional Item Attachment:

File name: Picture 2.png                  Size:23 KB


    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?16769>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to