Follow-up Comment #3, patch #2811 (project freeciv):

> At least g++ side has had static_assert since 4.3. One should 
> check if also gcc supports it. 
Answer appears to be: only since 4.6
<http://gcc.gnu.org/gcc-4.6/changes.html#c>. I think we probably have to wait
a year or two for that version to be used "99.5% of the time" (well, at least
I don't even have 4.5 yet; 4.3 is standard on my system).
Also, it's not clear to me whether you can get at it without specifying
"-std=c1x", and I'm not sure if our code is ready to be compiled with that
option.

So, I'll probably stick with the nasty version in the patch for now.

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?2811>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to