Update of patch #3020 (project freeciv):

         Planned Release:                         => 2.4.0, 2.5.0           

    _______________________________________________________

Follow-up Comment #1:

>From techincal perspective soundsets are equivalent to tilesets. When ever
there is development in respective code, there will be compatibility break. It
just happens that in practice we've had not much development in sound front.
Scenarios are different since there we maintain backward compatibility. So, to
avoid nightmare when there *is* some sound capability development, I'm
strongly for keeping soundsets in version specific directory.

Actually, if we strictly follow what was decided about capability strings
before 2.3, 2.4 soundsets will be incompatible with 2.3 ones, just because
capability string is changed. Obviously that capability string change makes no
sense, so I think we should omit it.

I remembered that there already is soundset category, but maybe it was just
something I meant to do.

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?3020>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to