URL:
  <http://gna.org/bugs/?19888>

                 Summary: Gtk widget rearrangement options backward
compatibility measures won't work
                 Project: Freeciv
            Submitted by: jtn
            Submitted on: Mon Jul  2 22:42:37 2012
                Category: client
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: In Progress
             Assigned to: jtn
        Originator Email: 
             Open/Closed: Open
                 Release: 2.3.2
         Discussion Lock: Any
        Operating System: Any
         Planned Release: 2.3.3,2.4.0,2.5.0

    _______________________________________________________

Details:

In patch #1889 (which went into 2.3.0), I merged two boolean options into one
enumerated one.
I put in some code which attempted to give a smooth upgrade from 2.2 and prior
by reading the old boolean options and choosing the appropriate enumerated
one.
I don't know what I was thinking, but it looks like I gave the options I read
the wrong names ("gui_gtk_*" rather than "gui_gtk2_*"). So I don't think this
can ever have worked. (I thought I tested it at the time, but...)

Well, it's not yet so late that it's not worth fixing.




    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?19888>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to