URL:
  <http://gna.org/bugs/?19976>

                 Summary: modpack needs libm
                 Project: Freeciv
            Submitted by: syntron
            Submitted on: Tue 24 Jul 2012 08:30:03 PM CEST
                Category: module installer
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: None
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: S2_4 (svn21612), trunk (svn21614)
         Discussion Lock: Any
        Operating System: GNU/Linux
         Planned Release: 

    _______________________________________________________

Details:

I did try to get the up-to-date freeciv packages at
https://build.opensuse.org/project/show?project=home%3Asyntron%3Afreeciv to
compile again (S2_3, S2_4, trunk). Besides a strange compile error only for
i586 (bug #19975) I did found that I had to add -lm as hard dependency for
linking the included lua libraries (needed for the modpack tool as there is no
other dependency including it). Lua provides mathematic functions (at least
tan()) and thus requires to be linked with this lib. A quick and dirty hack is
attached. It is needed for S2_4 and trunk in combination with opensuse 12.1 or
tumbleweed.



    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Tue 24 Jul 2012 08:30:03 PM CEST  Name: freeciv-lua_libm.diff  Size:
333B   By: syntron

<http://gna.org/bugs/download.php?file_id=16184>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?19976>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to