Follow-up Comment #3, bug #19904 (project freeciv):

I've seen this quite regularly, but not reproducible cases. It seems that unit
unloading method does not matter - I've seen it with units simply moving out
of boat, ships Shift+T unloading in cities, unloading at coast.

Maybe related thing is that in a coastal city where I were loading units to
ship there was more to load (from main map) than I anticipated. Once I opened
city screen to check the situation, it was revealed to me that I had loading
also those units that were supposed to be fortified to the city. I unloaded
those units one by one (via city screen present units -> menu). That went
fine. But as I were fortifying last one them, another one of the units got
unfortified. I fortified that, and again another (seemingly random) unit got
unfortified. I continued this a while, and found out that putting unit on
Sentry worked the same - random other unit lost its fortified or sentried
activity.
I then moved ship (with its single passanger (which was sentried all the time
- it never lost that status, by the way - not that I know when it had first
became sentried)) out of the city, and tried to fortify units remaining in the
city again. This time it worked just as it should.

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?19904>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to